Gentoo Archives: gentoo-user

From: thelma@×××××××××××.com
To: Gentoo mailing list <gentoo-user@l.g.o>
Subject: [gentoo-user] error while loading shared libraries: libstdc++.so.6:
Date: Tue, 02 Jan 2018 17:11:33
Message-Id: fbd4a7f0-9189-f380-ba05-773bfa975465@sys-concept.com
I was installing some brother driver simply run:
# tar zxvf ./hl5370dwlpr-2.0.3-1.i386.tar.gz -C /
./
./usr/
./usr/local/
./usr/local/Brother/
./usr/local/Brother/lpd/
./usr/local/Brother/lpd/psconvert2
./usr/local/Brother/lpd/filterHL5370DW
./usr/local/Brother/lpd/rawtobr2
./usr/local/Brother/inf/
./usr/local/Brother/inf/setupPrintcap
./usr/local/Brother/inf/paperinf
./usr/local/Brother/inf/brHL5370DWfunc
./usr/local/Brother/inf/braddprinter
./usr/local/Brother/inf/brHL5370DWrc
./usr/lib/
./usr/lib/libbrcomplpr2.so
./usr/bin/
./usr/bin/brprintconflsr2
./var/
./var/spool/
./var/spool/lpd/
./var/spool/lpd/HL5370DW/

# tar zxvf ./cupswrapperHL5370DW-2.0.4-1.i386.tar.gz -C /
./
./usr/
./usr/local/
./usr/local/Brother/
./usr/local/Brother/cupswrapper/
./usr/local/Brother/cupswrapper/brcupsconfig3
./usr/local/Brother/cupswrapper/cupswrapperHL5370DW-2.0.4

Now, I can not run any emerge, eix etc command, I'm getting: 
eix: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

bash: emerge: command not found

However libstdc++ exists: 

locate libstdc++.so.6
/usr/lib64/gcc/x86_64-pc-linux-gnu/5.4.0/libstdc++.so.6
/usr/lib64/gcc/x86_64-pc-linux-gnu/5.4.0/libstdc++.so.6.0.21
/usr/lib64/gcc/x86_64-pc-linux-gnu/5.4.0/32/libstdc++.so.6
/usr/lib64/gcc/x86_64-pc-linux-gnu/5.4.0/32/libstdc++.so.6.0.21
/usr/lib64/gcc/x86_64-pc-linux-gnu/6.4.0/libstdc++.so.6
/usr/lib64/gcc/x86_64-pc-linux-gnu/6.4.0/libstdc++.so.6.0.22
/usr/lib64/gcc/x86_64-pc-linux-gnu/6.4.0/32/libstdc++.so.6
/usr/lib64/gcc/x86_64-pc-linux-gnu/6.4.0/32/libstdc++.so.6.0.22
/usr/share/gdb/auto-load/usr/lib64/gcc/x86_64-pc-linux-gnu/5.4.0/libstdc++.so.6.0.21-gdb.py
/usr/share/gdb/auto-load/usr/lib64/gcc/x86_64-pc-linux-gnu/5.4.0/32/libstdc++.so.6.0.21-gdb.py
/usr/share/gdb/auto-load/usr/lib64/gcc/x86_64-pc-linux-gnu/6.4.0/libstdc++.so.6.0.22-gdb.py
/usr/share/gdb/auto-load/usr/lib64/gcc/x86_64-pc-linux-gnu/6.4.0/32/libstdc++.so.6.0.22-gdb.py

lib -> lib64 (exist in "/")

-- 
Joseph

Replies