Gentoo Archives: gentoo-user

From: tuxic@××××××.de
To: Gentoo <gentoo-user@l.g.o>
Subject: [gentoo-user] kicad failed to compile after update
Date: Sun, 10 May 2020 06:49:27
Message-Id: 20200510064914.ii5awyrxl7ukvhmg@solfire
Hi,

this morning I had a massive update of my system.

Beside others kicad failed to recompile with this message

Calculating dependencies... done!
 * Dependencies could not be completely resolved due to
 * the following required packages not being installed:
 * 
 *   >=dev-libs/boost-1.61:0/1.72.0=[context,nls,threads] pulled in by:
 *     sci-electronics/kicad-5.1.5-r1
 * 
 *   >=dev-libs/boost-1.61:0/1.72.0=[context,nls,threads,python,python_targets_python3_6(-)] pulled in by:
 *     sci-electronics/kicad-5.1.5-r1
 * 
 *   >=dev-libs/boost-1.61:=[context,nls,threads,python,python_targets_python3_6(-)] pulled in by:
 *     sci-electronics/kicad-5.1.5-r1
 * 
 *   dev-python/wxpython:4.0[python_targets_python3_6(-)] pulled in by:
 *     sci-electronics/kicad-5.1.5-r1
 * 
 *   media-libs/glew:0/2.1= pulled in by:
 *     sci-electronics/kicad-5.1.5-r1


:
[I] dev-libs/boost
     Available versions:  1.72.0-r1(0/1.72.0)^t (~)1.73.0(0/1.73.0)^t {bzip2 context debug doc icu lzma mpi +nls numpy python static-libs +threads tools zlib zstd ABI_MIPS="n32 n64 o32" ABI_RISCV="lp64 lp64d" ABI_S390="32 64" ABI_X86="32 64 x32" PYTHON_TARGETS="python2_7 python3_6 python3_7 python3_8"}
     Installed versions:  1.73.0(0/1.73.0)^t(06:38:51 AM 05/10/2020)(bzip2 context nls python threads zlib -debug -doc -icu -lzma -mpi -numpy -static-libs -tools -zstd ABI_MIPS="-n32 -n64 -o32" ABI_RISCV="-lp64 -lp64d" ABI_S390="-32 -64" ABI_X86="64 -32 -x32" PYTHON_TARGETS="python2_7 python3_7 -python3_6 -python3_8")
     Homepage:            https://www.boost.org/
     Description:         Boost Libraries for C++


Is it possible to install the older version of boost somehow "in
parallel" withouth screwing up the rest of the system?

Cheers!
Meino

Replies

Subject Author
Re: [gentoo-user] kicad failed to compile after update Ashley Dixon <ash@××××××××××.uk>
Re: [gentoo-user] kicad failed to compile after update Jack <ostroffjh@×××××××××××××××××.net>