Gentoo Archives: gentoo-user

From: Jason Stubbs <jstubbs@g.o>
To: gentoo-user@l.g.o
Subject: Re: [gentoo-user] Portage
Date: Sun, 29 Jan 2006 23:42:00
Message-Id: 200601300830.37396.jstubbs@gentoo.org
In Reply to: [gentoo-user] Portage by Tony Davison
On Monday 30 January 2006 02:57, Tony Davison wrote:
> Portage -2.1_pra4-r1 has a new dependency of dev-python/pycrypto-2.0.1, > anyone know why? > I only askbecausi it is new and nothing else (on this box) depends on it, so > I wondered what it would break.
It's to support non-MD5 hashing algorithms. If you have a look at portage's Manifest, you'll see MD5, RMD160 and SHA256 hashes for all files. These are generatable and verifiable from 2.1_pre4. -- Jason Stubbs -- gentoo-user@g.o mailing list