Gentoo Archives: gentoo-user

From: Philip Webb <purslow@××××××××.net>
To: gentoo-user@l.g.o
Subject: Re: [gentoo-user] libtool 2.x upgrade
Date: Fri, 26 Feb 2010 04:04:28
Message-Id: 20100226032532.GE4353@ca.inter.net
In Reply to: [gentoo-user] libtool 2.x upgrade by bn
100226 bn wrote:
> I have a stable x86 system that requires still a bit of updating, > among those libtool and gcc. Since I need the system to be usable *now* > for work reasons, I don't feel like updating gcc and rebuilding it all > with an emerge -e system / emerge -e world, > but more and more packages want to upgrade to libtool 2.x > Is it safe to upgrade libtool without (1)rebuilding gcc too > and (2)rebuilding system/world?
FWIW I've been using Libtool 2.2.6b since 091212 & GCC 4.3.4 since 091018 without any problems I can remember; I kept GCC 4.1.2 installed as well & use 'quickpkg' to make back-ups. You shouldn't need to rebuild anything else till it comes up naturally. I never do 'emerge world' without '-Dup', but emerge pkgs individually. -- ========================,,============================================ SUPPORT ___________//___, Philip Webb ELECTRIC /] [] [] [] [] []| Cities Centre, University of Toronto TRANSIT `-O----------O---' purslowatchassdotutorontodotca