Gentoo Archives: gentoo-user

From: John Covici <covici@××××××××××.com>
To: gentoo-user@l.g.o
Subject: [gentoo-user] preparing for profile switch -- major problem
Date: Thu, 07 Dec 2017 05:44:11
Message-Id: m3zi6vjdnh.wl-covici@ccs.covici.com
Hi. In preparing for the profile switch and the emerge -e world, I
have run into a serious problem with perl.  I think I saw on this list
where perl 5.26 was going to have problems -- maybe until it is
stabilized -- but if I mask it off,  I get the following:

!!! All ebuilds that could satisfy "=dev-lang/perl-5.26*" have been
    masked.
    !!! One of the following masked packages is required to complete
    your request:
    - dev-lang/perl-5.26.9999::gentoo (masked by: package.mask,
    missing keyword)
    - dev-lang/perl-5.26.1-r1::gentoo (masked by: package.mask)
    - dev-lang/perl-5.26.1::gentoo (masked by: package.mask)
    - dev-lang/perl-5.26.0::gentoo (masked by: package.mask)

(dependency required by "virtual/perl-Test-Harness-3.380.0::gentoo"
[ebuild])
(dependency required by "perl-core/ExtUtils-MakeMaker-7.240.0::gentoo"
[ebuild])
(dependency required by
"virtual/perl-ExtUtils-MakeMaker-7.240.0::gentoo" [ebuild])
(dependency required by "dev-perl/Class-Singleton-1.500.0::gentoo"
[ebuild])
(dependency required by "media-video/clive-2.3.0.1::gentoo" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

If I don't mask it off, I get the following: (just emerging perl by
itself)


!!! Multiple package instances within a single package slot have been
    pulled
    !!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.26.1-r1:0/5.26::gentoo, ebuild scheduled for merge)
  pulled in by
      =dev-lang/perl-5.26* required by
  (virtual/perl-ExtUtils-Manifest-1.700.0-r4:0/0::gentoo, installed)
      ^              ^^^^^
	     dev-lang/perl (Argument)
		    (and 13 more with the same problems)

  (dev-lang/perl-5.24.3:0/5.24::gentoo, installed) pulled in by
      dev-lang/perl:0/5.24= required by
      (virtual/perl-Test-Simple-1.1.14-r3:0/0::gentoo, installed)
	                  ^^^^^^^^
				       =dev-lang/perl-5.24* required by
      (virtual/perl-Term-ANSIColor-4.40.0-r1:0/0::gentoo, installed)
	     ^              ^^^^^
		    dev-lang/perl:0/5.24= required by
      (dev-perl/XML-Twig-3.520.0:0/0::gentoo, installed)
	                  ^^^^^^^^
				       (and 261 more with the same problems)

NOTE: Use the '--verbose-conflicts' option to display parents omitted
above

!!! The slot conflict(s) shown above involve package(s) which may need
    to
    !!! be rebuilt in order to solve the conflict(s). However, the
    following
    !!! package(s) cannot be rebuilt for the reason(s) shown:

  (virtual/perl-Test-Simple-1.1.14-r3:0/0::gentoo, installed): ebuild
  is masked or unavailable


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


Thanks in advance for any suggestions.


-- 
Your life is like a penny.  You're going to lose it.  The question is:
How do
you spend it?

         John Covici
         covici@××××××××××.com

Replies

Subject Author
Re: [gentoo-user] preparing for profile switch -- major problem Michael Orlitzky <mjo@g.o>
Re: [gentoo-user] preparing for profile switch -- major problem Alan McKinnon <alan.mckinnon@×××××.com>