Gentoo Archives: gentoo-user

From: John Campbell <jdc.rpv@×××.net>
To: gentoo-user@l.g.o
Subject: Re: [gentoo-user] All ~arch users: do not update python
Date: Tue, 03 Aug 2010 03:35:03
Message-Id: 4C578E20.7020308@cox.net
In Reply to: [gentoo-user] All ~arch users: do not update python by Nikos Chantziaras
1 On 08/02/2010 05:53 PM, Nikos Chantziaras wrote:
2 > Updating python to 2.6.5_p20100801 will break portage. emerge will stop
3 > working after that and there's no information on how to recover from
4 > that right now (because emerge won't work, you can't downgrade to the
5 > previous, working python version.)
6 >
7 > Bug for this issue: http://bugs.gentoo.org/show_bug.cgi?id=330937
8
9 /usr/bin/python3.1 emerge =lang-python/python-2.6.5-r3
10
11 Assuming of course you've got python3.1 installed in another slot.