Gentoo Archives: gentoo-user

From: Jeffrey Rollin <jeff.rollin@×××××.com>
To: gentoo-user@l.g.o
Subject: [gentoo-user] Problem installing subversion
Date: Mon, 29 Jan 2007 09:58:05
Message-Id: 200701290951.48726.jeffrey.rollin@gmail.com
Hi

I'm having the following problem installing subversion:

Traceback (most recent call last):
  File "/usr/bin/depend-java-query", line 85, in ?
    (options, args) = parser.parse_args()
  File "/usr/lib/python2.4/optparse.py", line 1275, in parse_args
    stop = self._process_args(largs, rargs, values)
  File "/usr/lib/python2.4/optparse.py", line 1315, in _process_args
    self._process_long_opt(rargs, values)
  File "/usr/lib/python2.4/optparse.py", line 1390, in _process_long_opt
    option.process(opt, value, values, self)
  File "/usr/lib/python2.4/optparse.py", line 707, in process
    return self.take_action(
  File "/usr/lib/python2.4/optparse.py", line 726, in take_action
    self.callback(self, opt, value, parser, *args, **kwargs)
  File "/usr/bin/depend-java-query", line 49, in get_vm
    vm = verman.get_vm(value)
  File "/usr/share/java-config-2/pym/java_config/VersionManager.py", line 151, 
in get_vm
    raise Exception("Couldn't find suitable VM. Possible invalid dependency 
string.")
Exception: Couldn't find suitable VM. Possible invalid dependency string.
 * Unable to determine VM for building from dependencies:
NV_DEPEND: apache2? ( =net-www/apache-2* )
        >=dev-libs/apr-util-0.9.5
        python? ( >=dev-lang/python-2.0 )
        perl? ( >=dev-lang/perl-5.8.6-r6
                !=dev-lang/perl-5.8.7 )
        ruby? ( >=dev-lang/ruby-1.8.2 )
        !nowebdav? ( >=net-misc/neon-0.26 )
        berkdb? ( =sys-libs/db-4* )
        zlib? ( sys-libs/zlib )
        java? ( >=virtual/jdk-1.4 )
        emacs? ( virtual/emacs )
        java? ( >=virtual/jdk-1.4 )
        >=sys-devel/autoconf-2.59  java? ( >=dev-java/java-config-2.0.19-r1 
>=sys-apps/portage-2.1_pre1 )
VNEED: !!! ERROR: dev-util/subversion-1.3.2-r3 failed. Call stack: ebuild.sh, line 1562: Called dyn_setup ebuild.sh, line 664: Called pre_pkg_setup java-pkg-opt-2.eclass, line 51: Called java-pkg-opt-2_pkg_setup java-pkg-opt-2.eclass, line 38: Called java-pkg_init java-utils-2.eclass, line 1723: Called java-pkg_switch-vm java-utils-2.eclass, line 2111: Called die !!! Failed to determine VM for building. !!! If you need support, post the topmost build error, and the call stack if relevant. !!! When you file a bug report, please include the following information: GENTOO_VM= CLASSPATH="" JAVA_HOME="" JAVACFLAGS="" COMPILER="" and of course, the output of emerge --info Please help! Jeff -- gentoo-user@g.o mailing list

Replies

Subject Author
Re: [gentoo-user] Problem installing subversion "Bo Ørsted Andresen" <bo.andresen@××××.dk>