Gentoo Archives: gentoo-user

From: Kaushal Shriyan <kaushalshriyan@×××××.com>
To: gentoo-user@l.g.o
Subject: Re: [gentoo-user] autossh
Date: Wed, 09 Sep 2009 06:04:53
Message-Id: 6b16fb4c0909082304m67d27053ie8bb31bfe17fa51d@mail.gmail.com
In Reply to: Re: [gentoo-user] autossh by Joshua Murphy
1 On Wed, Sep 9, 2009 at 1:09 AM, Joshua Murphy<poisonbl@×××××.com> wrote:
2 > On Tue, Sep 8, 2009 at 7:12 AM, Kaushal Shriyan<kaushalshriyan@×××××.com> wrote:
3 >> Hi
4 >>
5 >> I am having issue with autossh hostxxxx, I get
6 >>
7 >> autossh[13221]: checking for grace period, tries = 0
8 >> autossh[13221]: starting ssh (count 1)
9 >> autossh[13221]: ssh child pid is 13224
10 >> autossh[13221]: check on child 13224
11 >> autossh[13221]: set alarm for 600 secs
12 >> autossh[13224]: execing /usr/bin/ssh
13 >>
14 >> My Autossh setting in my .bashrc are as  below
15 >>
16 >> export AUTOSSH_GATETIME=0
17 >> export AUTOSSH_POLL=100
18 >> export AUTOSSH_PORT=20020
19 >> export AUTOSSH_DEBUG=1
20 >>
21 >> When i test by disconnecting and reconnecting the internet, It takes
22 >> 10mins to prompt for a password. Can this time interval be reduced ?
23 >>
24 >> Thanks and Regards,
25 >>
26 >> Kaushal
27 >
28 > Where are you starting autossh from? The AUTOSSH_POLL variable in your
29 > .bashrc is, it would appear, being disregarded in whatever context
30 > autossh is starting in, otherwise you'd be seeing an up to 1 minute,
31 > 40 second delay on reconnecting, not 10 minutes.
32 >
33 > --
34 > Poison [BLX]
35 > Joshua M. Murphy
36 >
37 >
38
39 Hi Joshua
40
41 I am starting autossh somehost from the same gnome-terminal tab
42 session where my .bashrc is located
43
44 Any further clue ?
45
46 Thanks and Regards,
47
48 Kaushal

Replies

Subject Author
Re: [gentoo-user] autossh Willie Wong <wwong@××××××××××××××.edu>