Gentoo Archives: gentoo-user

From: walt <w41ter@×××××.com>
To: gentoo-user@l.g.o
Subject: [gentoo-user] Re: OpenSP build fails
Date: Wed, 23 Apr 2014 01:07:28
Message-Id: lj73ni$7b1$1@ger.gmane.org
In Reply to: [gentoo-user] OpenSP build fails by Nikita Tropin
1 On 04/22/2014 08:42 AM, Nikita Tropin wrote:
2 > Hi, I'm trying to update Gentoo with I_KNOW_WHAT_I_AM_DOING=1 emerge
3 > --deep --update --newuse --with-bdeps=y @world
4 >
5 > and process fails on OpenSP-1.5.2-r3. I am tried to compile it myself
6 > and find those lacking `new.h' mentioned in build.log. I found in
7 > include/xnew.h ifdef construction that responsible of choosing
8 > appropriate file (<new> or <new.h>), find utility not found any
9 > `new.h' on my /usr or build directory of OpenSP in my home dir,
10 > however `new' was found -
11 > /usr/lib64/gcc/x86_64-pc-linux-gnu/4.7.3/include/g++-v4/new
12
13 Any time I see build errors in c++ programs I suspect libtool.
14 (No, I can't explain why, I just do ;)
15
16 For that reason I'd suggest running fix_libtool_files.sh, just
17 in case your gcc ebuild didn't do it automatically.
18
19 FWIW, opensp builds successfully for me and my configure logs
20 look very much like yours (I'm using gcc-4.8.2/~amd64, though.)

Replies

Subject Author
Re: [gentoo-user] Re: OpenSP build fails Nikita Tropin <posixivist32@×××××.com>