Gentoo Archives: gentoo-user

From: Alan McKinnon <alan.mckinnon@×××××.com>
To: gentoo-user@l.g.o
Subject: Re: [gentoo-user] blockage
Date: Sun, 22 Mar 2015 09:24:38
Message-Id: 550E8A48.9040409@gmail.com
In Reply to: [gentoo-user] blockage by lee
On 22/03/2015 05:24, lee wrote:
> Hi, > > when trying to update with 'emerge -j 8 -a --update --deep > --with-bdeps=y @world' after 'emerge --sync', I'm getting the following > message: > > > * Error: The above package list contains packages which cannot be > * installed at the same time on the same system. > > (sys-process/procps-3.3.9-r2:0/0::gentoo, installed) pulled in by > sys-process/procps required by @system > > (sys-apps/util-linux-2.25.2-r2:0/0::gentoo, ebuild scheduled for merge) pulled in by > >=sys-apps/util-linux-2.24.1-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-apps/util-linux-2.24.1-r3[abi_x86_64 > (-)]) required by (x11-libs/libSM-1.2.2-r1:0/0::gentoo, installed) > sys-apps/util-linux required by (app-text/xmlto-0.0.26:0/0::gentoo, installed) > sys-apps/util-linux required by (app-text/build-docbook-catalog-1.19.1:0/0::gentoo, installed) > sys-apps/util-linux[static-libs?] (sys-apps/util-linux) required by (sys-fs/zfs-9999:0/0::gentoo, installed) > >=sys-apps/util-linux-2.20 required by (sys-fs/udev-216:0/0::gentoo, installed) > >=sys-apps/util-linux-2.16 required by (sys-fs/e2fsprogs-1.42.12:0/0::gentoo, installed) > >=sys-apps/util-linux-2.16 required by (dev-libs/apr-1.5.0-r2:1/1::gentoo, installed) > sys-apps/util-linux required by @system > sys-apps/util-linux required by (net-fs/nfs-utils-1.3.1-r5:0/0::gentoo, installed) > sys-apps/util-linux required by (app-emulation/lxc-1.0.7:0/0::gentoo, installed) > > (sys-apps/sysvinit-2.88-r4:0/0::gentoo, ebuild scheduled for merge) pulled in by > >=sys-apps/sysvinit-2.86-r6 required by (sys-apps/openrc-0.13.11:0/0::gentoo, installed) > <=sys-apps/sysvinit-2.88-r4 required by (sys-power/apcupsd-3.14.8-r2:0/0::gentoo, installed) > > > I don't understand this message. What is blocked by what and why, and > what am I supposed to do?
There's more to the output that you haven't posted, specifically the list of blockers. They are in the main list of packages to be emerged and start with lines like [blocked ] The output above shows in full detail why portage thinks procps, util-linux and sysvinit need to be installed, but doesn't show why they can't be installed on the same system at the same time. The list of blockers shows that. -- Alan McKinnon alan.mckinnon@×××××.com

Replies

Subject Author
Re: [gentoo-user] blockage lee <lee@××××××××.de>