Gentoo Archives: gentoo-user

From: tuxic@××××××.de
To: Gentoo <gentoo-user@l.g.o>
Subject: [gentoo-user] Help...can't decipher emerge oracle...
Date: Wed, 15 Nov 2017 16:50:57
Message-Id: 20171115165037.ilmhoi7zwiltzwru@solfire
Hi,

From emerge I got this """info""":



 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-libs/glibc-2.25-r9:2.2/2.2::gentoo, installed) pulled in by
    >=sys-libs/glibc-2.23[multilib?] (>=sys-libs/glibc-2.23) required by (dev-java/icedtea-bin-3.6.0:8/8::gentoo, installed)
    sys-libs/glibc[rpc(-)] required by (net-fs/autofs-5.1.3:0/0::gentoo, installed)
    >=sys-libs/glibc-2.6.1 required by (x11-drivers/nvidia-drivers-387.22:0/387::gentoo, installed)
    sys-libs/glibc required by (app-arch/rar-5.5.0_p20170811:0/0::gentoo, installed)
    >=sys-libs/glibc-2.7 required by (sys-apps/iproute2-4.14.0:0/0::gentoo, ebuild scheduled for merge)
    >=sys-libs/glibc-2.17 required by (dev-lang/ghc-8.0.2:0/8.0.2::gentoo, installed)
    sys-libs/glibc:2.2 required by (virtual/libc-1:0/0::gentoo, installed)
    sys-libs/glibc required by (app-office/openoffice-bin-4.1.3:0/0::gentoo, installed)
    sys-libs/glibc required by @selected
    >=sys-libs/glibc-2.8:2.2 required by (media-video/vlc-2.2.6-r2:0/5-8::gentoo, installed)
    >=sys-libs/glibc-2.8 required by (sys-devel/gcc-4.9.4:4.9.4/4.9.4::gentoo, installed)
    >=sys-libs/glibc-2.8 required by (sys-devel/gcc-5.4.0-r3:5.4.0/5.4.0::gentoo, installed)
    >=sys-libs/glibc-2.13 required by (sys-devel/gcc-6.4.0:6.4.0/6.4.0::gentoo, installed)

  (net-libs/libnsl-1.1.0-r1:0/2::gentoo, ebuild scheduled for merge) pulled in by
    net-libs/libnsl:0= required by (app-emulation/hercules-3.12:0/0::gentoo, installed)
    net-libs/libnsl:0= required by (app-text/opensp-1.5.2-r6:0/0::gentoo, ebuild scheduled for merge)
    net-libs/libnsl:0 required by @__auto_slot_operator_replace_installed__

...for me it seems, that I need a lot of different glibc versions and
currently I dont know, how to get out of this mess...

I would be happy, if someone could help me...

Cheers
Meino

Replies

Subject Author
Re: [gentoo-user] Help...can't decipher emerge oracle... "Jan Chren (rindeal)" <dev.rindeal@×××××.com>
Re: [gentoo-user] Help...can't decipher emerge oracle... "Andreas K. Huettel" <dilfridge@g.o>