Gentoo Archives: gentoo-user

From: Hamie <hamish@××××××××××××××.com>
To: gentoo-user@l.g.o
Subject: Re: [gentoo-user] Re: XV locks up X server after recent update
Date: Fri, 23 Feb 2007 16:34:32
Message-Id: 200702231627.12458.hamish@travellingkiwi.com
In Reply to: [gentoo-user] Re: XV locks up X server after recent update by Grant Edwards
1 On Wednesday 21 February 2007 17:37, Grant Edwards wrote:
2 > On 2007-02-21, Hamie <hamish@××××××××××××××.com> wrote:
3 > >> The ati-drivers package was updated from 8.27.10-r1 to 8.32.5.
4 > >> Rolling it back to 8.27.10-r1 made xv work again. The lock up
5 > >> occurred with xorg-xserver versions 1.1.1-r1, 1.1.1-r4,
6 > >> 1.2.0-r1. ati-drivers 8.33.6-r1 also locked up.
7 >
8 > On my list of things to do is check to see if 8.28.8 with the
9 > 2.6.19 patch works...
10 >
11 > > Hmm... My ati-drivers actually crashes the XServer completely.
12 > > And (Usually) restarts (Sometimes kdm just gives up as well).
13 > >
14 > > I did attempt to raise a support request about it... And got
15 > > an email back from ATI/AMD saying I shuld be thankful for what
16 > > they've given me & not to bother them about it...
17 >
18 > I was bying ATI cards because the open-source driver supported
19 > DRI (it was a bit flakey, but it mostly "just worked"). But,
20 > that ended with the 92xx series. My experience (and the
21 > general consensus, AFAICT) is that the NVidia closed-source
22 > drivers are far less problematic than the ATI ones.
23 >
24 > I've got a 3 year old ATI card that ATI doesn't support at all
25 > anymore with Linux drivers. I've got a 6 year old NVidia card
26 > that still works perfectly and all I had to do is "emerge
27 > nvidia-drivers"
28 >
29 > So I think NVidia is the way to go in general.
30 >
31 > [The problem is that you don't get much of a choice with
32 > laptops. My IBM ThinkPad was too good a deal to pass up even
33 > though it came with an ATI M300.]
34 >
35
36 If you have anything up to X600 (Maybe even X700) graphics (basically 9600 on
37 PCIe) then the open source drivers should work fine... Mine is an X1400
38 sadly, so I don't even get LCD native resolution without the damned ATI
39 drivers (Because it's flakey as hell with their DRI, and suspend to RAM
40 doesn't work... Still... So why even bother).
41
42
43 Hamish.

Replies

Subject Author
[gentoo-user] Re: XV locks up X server after recent update Grant Edwards <grante@××××.com>