Gentoo Archives: gentoo-user

From: Marat BN <maratbn@×××××.com>
To: gentoo-user@l.g.o
Subject: [gentoo-user] 'emerge --update @world -pv' keeps trying to upgrade to a masked package
Date: Wed, 14 Oct 2015 00:54:15
Message-Id: 561DA7A2.3000206@gmail.com
Hello there,

I'm having a curious problem trying to update my system.

I issue the command:

emerge --update @world -pv


Portage comes back with the following:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

net-wireless/bluez:0

   (net-wireless/bluez-4.101-r9:0/0::gentoo, installed) pulled in by
       net-wireless/bluez:0/0= required by
(media-sound/pulseaudio-5.0-r7:0/0::gentoo, installed)
                                           ^^^^^                       
                                                                       
                                                                       
                                    
       <net-wireless/bluez-5 required by
(net-wireless/blueman-1.23-r2:0/0::maratbn, installed)
       ^                                     ^                         
                                                                       
                                                                       
                                                                        

   (net-wireless/bluez-5.33:0/3::gentoo, ebuild scheduled for merge)
pulled in by
       >=net-wireless/bluez-5 required by
(net-misc/networkmanager-1.0.6:0/0::gentoo, ebuild scheduled for merge)
       ^^                                     ^                         
                                                                       
                                                                       
                                                                       
                                  


But I have the following line in my '/etc/portage/package.mask':

=net-misc/networkmanager-1.0.6:0/0::gentoo


So doesn't this tell portage not to upgrade to it?   Why does it still
schedule it for merge?


Thanks a lot,
Marat

Replies