Gentoo Archives: gentoo-user

From: "J. Roeleveld" <joost@××××××××.org>
To: gentoo-user@l.g.o
Subject: Re: [gentoo-user] 4 versions of binutils: requesting confirmation for eselect set
Date: Wed, 17 Apr 2019 06:08:34
Message-Id: 13298282.ToTCueKQnU@eve
In Reply to: [gentoo-user] 4 versions of binutils: requesting confirmation for eselect set by allan gottlieb
1 On Monday, April 15, 2019 4:40:44 PM CEST allan gottlieb wrote:
2 > On one of my machines I see
3 >
4 > gottlieb@E6430 ~ $ eselect binutils list
5 > [1] x86_64-pc-linux-gnu-2.28.1 *
6 > [2] x86_64-pc-linux-gnu-2.29.1
7 > [3] x86_64-pc-linux-gnu-2.30
8 > [4] x86_64-pc-linux-gnu-2.31.1
9 >
10 > But I also see
11 >
12 > gottlieb@E6430 ~ $ eix -I -e binutils
13 > [?] sys-devel/binutils
14 > ...
15 > (2.28.1) [M]2.28.1
16 > (2.29.1) [M]2.29.1-r1
17 > (2.30) 2.30-r4
18 > (2.31) 2.31.1-r4 ~2.31.1-r5
19 > ...
20 >
21 > So I am using a masked version of binutils, which seems bad.
22 >
23 > I presume I should do
24 > eselect binutils set 4
25 >
26 > I am asking for confirmation since I realize breaking binutils
27 > is not fun.
28 >
29 > thank you,
30 > allan
31
32 I only have the latest. Do you run " emerge --depclean " after updates?
33
34 --
35 Joost