Gentoo Archives: gentoo-user

From: Bill Kenworthy <billk@×××××××××.au>
To: gentoo-user@l.g.o
Subject: Re: [gentoo-user] xorg 1.20.x not working
Date: Sun, 10 Feb 2019 22:53:45
Message-Id: 6f73c199-7292-8967-e302-7afac2f5f08e@iinet.net.au
In Reply to: Re: [gentoo-user] xorg 1.20.x not working by John Covici
On 11/2/19 3:51 am, John Covici wrote:
> On Sun, 10 Feb 2019 11:57:27 -0500, > Andrew Savchenko wrote: >> [1 <text/plain; UTF-8 (quoted-printable)>] >> On Sun, 10 Feb 2019 10:21:21 -0600 Dale wrote: >>> Andrew Savchenko wrote: >>>> On Wed, 16 Jan 2019 15:18:37 +0800 Bill Kenworthy wrote: >>>>> Hi, >>>>> >>>>> I have a problem with any of the xorg-server 1.20.x series where I can >>>>> start simple apps like xterm but more complexapps like firefox and >>>>> thunderbird (for example) hang X with no erros in dmessage, log, >>>>> Xorg.0.log, .xsession-errors etc.  The mouse can move but no clicks are >>>>> accepted.  I have also recently run emerge -ep  with the profile upgrade >>>>> (using 1.19 as I needed to use the system at the time) and a previous >>>>> rebuild of almost everything with 1.20 installed with no change. >>>> You need to rebuild all x11-drivers after xorg update. Input >>>> problems you are describing are likely caused by modules built for >>>> older xorg version. >>>> >>>> Try: >>>> # emerge -av $(eix -IC x11-drivers --only-names) >>>> >>>> Best regards, >>>> Andrew Savchenko >>> Isn't one of these supposed to do that? >>> >>> emerge @module-rebuild >>> >>> emerge @x11-module-rebuild >>> >>> I think the top one is the correct one.  >> The top one will rebuild kernel modules. So it has nothing to do >> with xorg. The bottom one is correct, I just forgot about it. > I have much worse problems, whenever I start gdm, the screen shows the > same content as the virtual console where I started gdm. Gdm is > running, x-server is running, but the screen is not showing it. I did > compile all the drivers, so this is very strange. >
Another me too ... same problem, same symptoms, complete rebuild including modules.  After hours of work I have had to mask 1.20 so I can have a working system. BillK

Replies

Subject Author
Re: [gentoo-user] xorg 1.20.x not working Alan Grimes <alonzotg@×××××××.net>