Gentoo Archives: gentoo-user

From: Alan McKinnon <alan.mckinnon@×××××.com>
To: gentoo-user@l.g.o
Subject: Re: [gentoo-user] source repository could not be determined
Date: Fri, 26 Feb 2010 21:25:40
Message-Id: 201002262322.32321.alan.mckinnon@gmail.com
In Reply to: [gentoo-user] source repository could not be determined by Joseph
On Friday 26 February 2010 23:12:18 Joseph wrote:
> I'm trying to re-emerge package kbarcode but it keeps complaing: > that the source repository could not be determined > > emerge -pv kbarcode > > These are the packages that would be merged, in order: > > Calculating dependencies... done! > [ebuild R ] app-text/kbarcode-2.0.7 USE="-debug% -doc -xinerama%" 0 kB > [?=>1] > > Total: 1 package (1 reinstall), Size of downloads: 0 kB > Portage tree and overlays: > [0] /usr/portage > [1] /usr/local/portage/layman/kde-sunset > [?] indicates that the source repository could not be determined > > How to fix it?
The error means that the package is no longer in portage or any of the overlays you are using. It's probably dead. Is it a KDE-3.5 package? If so, it will be in the kde-sunset overlay. -- alan dot mckinnon at gmail dot com

Replies

Subject Author
Re: [gentoo-user] source repository could not be determined Joseph <syscon780@×××××.com>