Gentoo Archives: gentoo-user

From: Daniel Frey <djqfrey@×××××.com>
To: gentoo-user@l.g.o
Subject: Re: [gentoo-user] And so the emerge spake: Let there be conflicts...and see, everything was chaos and sin...
Date: Sat, 25 Apr 2015 20:16:26
Message-Id: 553BF5F8.20008@gmail.com
In Reply to: [gentoo-user] And so the emerge spake: Let there be conflicts...and see, everything was chaos and sin... by Meino.Cramer@gmx.de
1 On 04/25/2015 09:07 AM, Meino.Cramer@×××.de wrote:
2 > Hi,
3 >
4 > A novice asks the master Emerge:
5 > "Is there Zen also in every upgrade, which will serve to Gentoo?"
6 >
7 > Master Emerge moved a little bit and spoke:
8 >
9 > WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:
10
11 Hah!
12
13 >
14 > x11-libs/libXfont:0
15 >
16 > (x11-libs/libXfont-1.5.1:0/0::gentoo, ebuild scheduled for merge) conflicts with
17 > <x11-libs/libXfont-1.5.0 required by (x11-base/xorg-server-1.12.4-r4:0/1.12.4::gentoo, installed)
18 > ^ ^^^^^
19
20 Emerge is trying to install libXfont 1.5.1 but the xorg-server version
21 installed requires 1.5.0.
22
23 >
24 > x11-proto/fontsproto:0
25 >
26 > (x11-proto/fontsproto-2.1.3:0/0::gentoo, ebuild scheduled for merge) conflicts with
27 > <x11-proto/fontsproto-2.1.3 required by (x11-libs/libXfont-1.4.9:0/0::gentoo, installed)
28 > ^ ^^^^^
29 > <x11-proto/fontsproto-2.1.3 required by (x11-base/xorg-server-1.12.4-r4:0/1.12.4::gentoo, installed)
30 > ^ ^^^^^
31 >
32
33 It can't upgrade fontsproto because the current installed version of
34 libXfont requires 2.1.3.
35
36 Looks like all these messages are thrown because of libXfont.
37
38 > The novice was buffled and did not understand a single word.
39 > He tries hard to circumvent any conflict with the master but
40 > finally he struggled and failed.
41
42 Looks like Master Emerge was confused by a circular dependency it could
43 not resolve.
44
45 Dan

Replies