Gentoo Archives: gentoo-user

From: Michael Schreckenbauer <grimlog@×××.de>
To: gentoo-user@l.g.o
Subject: Re: [gentoo-user] Very bad system response
Date: Thu, 08 Feb 2007 10:36:32
Message-Id: 200702081129.55304.grimlog@gmx.de
In Reply to: Re: [gentoo-user] Very bad system response by "Hemmann
1 Hi,
2
3 Am Mittwoch, 7. Februar 2007 21:19 schrieb Hemmann, Volker Armin:
4 > On Mittwoch, 7. Februar 2007, Michael Schreckenbauer wrote:
5 > > Hi,
6 > >
7 > > Am Mittwoch, 7. Februar 2007 12:35 schrieb Benno Schulenberg:
8 > > > Hemmann, Volker Armin wrote:
9 > > > > hdparm /dev/hda
10 > > > >
11 > > > > /dev/hda:
12 > > > > multcount = 16 (on)
13 > > > > IO_support = 1 (32-bit)
14 > > > > unmaskirq = 1 (on)
15 > > > > using_dma = 1 (on)
16 > > > > keepsettings = 0 (off)
17 > > > > readonly = 0 (off)
18 > > > > readahead = 256 (on)
19 > > > > geometry = 16383/255/63, sectors = 234493056, start = 0
20 > > >
21 > > > Maybe set readahead to a smaller value? Something like 8 or 16?
22 > > >
23 > > > At least that's what http://linuxgazette.net/issue79/punk.html
24 > > > advises. If you have specific reasons for the higher value, then
25 > > > please elaborate.
26 >
27 > it is a default setting I never touched?
28 > Aside from 'IO_support' everything is default.
29
30 same here.
31
32 > Oh, and I tried different io-scheds without any success.
33
34 anticipatory and deadline work better for me, but far from perfect. cfq is
35 unusable.
36
37 > > I believe there is a misunderstanding here. I am the one with the problem
38 > > not Volker :)
39 > we have both similar problems ;)
40
41 Ah! Nice to hear I am not alone! *g*
42 googling around, I found some people having a similar problem too, all of them
43 are using xfs as I do (eg http://www.thisishull.net/showthread.php?t=219580).
44 What's your fs? Mounting with nobarrier didn't work for me :(
45
46 Regards,
47 Michael
48 --
49 gentoo-user@g.o mailing list

Replies