Gentoo Archives: gentoo-user

From: Pandu Poluan <pandu@××××××.info>
To: gentoo-user@l.g.o
Subject: Re: [gentoo-user] mdev + xorg + Gnome up and running. :-)
Date: Thu, 15 Mar 2012 05:45:28
Message-Id: CAA2qdGUGchWX7vAxJMo_nEFtYhactvDT-eZhHE_XsRJukz9fVw@mail.gmail.com
In Reply to: [gentoo-user] mdev + xorg + Gnome up and running. :-) by Alan Mackenzie
1 On Mar 15, 2012 11:22 AM, "Alan Mackenzie" <acm@×××.de> wrote:
2 >
3 > Hi, Gentoo.
4 >
5 > Yes, I've got Gnome going under mdev. Thanks to Mike Edenfield for the
6 > tip about needing to configure things in xorg.conf.
7 >
8 > Here's how I did it:
9 >
10 > (i) Rebuild xorg-server without udev.
11 > * Insert this line into /etc/package.use:
12 >
13 > x11-base/xorg-server -udev
14 >
15 > * build the program with:
16 >
17 > emerge xorg-server
18 >
19 > (ii) Configure the keyboard and mouse explicitly in /etc/X11/xorg.conf
20 > (or wherever else you keep your xorg.conf).
21 > * Edit the two "InputDevice" sections to look like this. The critical
22 > lines are emphasised:
23 >
24 > Section "InputDevice"
25 > Identifier "Keyboard0"
26 > Driver "evdev" <--------------
27 > Option "Device" "/dev/input/event3" <--------------
28 > EndSection
29 >
30 > Section "InputDevice"
31 > Identifier "Mouse0"
32 > Driver "evdev" <--------------
33 > Option "Protocol" "auto"
34 > Option "Device" "/dev/input/event4" <--------------
35 > Option "ZAxisMapping" "4 5 6 7"
36 > EndSection
37 >
38 > Here's another section for your instructions, Walter. :-)
39 >
40
41 Great news! :-D
42
43 What about LVM2 automounting?
44
45 Rgds,