Gentoo Archives: gentoo-user

From: Mark Knecht <markknecht@×××××.com>
To: gentoo-user@l.g.o
Subject: [gentoo-user] Very old machine blocking/update questions
Date: Fri, 25 Apr 2008 21:15:15
Message-Id: 5bdc1c8b0804251415l532b0a5cq9899f93e020a783c@mail.gmail.com
1 Hi,
2 OK, so this machine I Was speaking of earlier seems ot have a
3 number of issues created by a profile update. I'm attempting to move
4 from 2005.0 to 2007.0. I'm using these documents as reference:
5
6 http://www.gentoo.org/doc/en/gentoo-upgrading.xml#doc_chap3
7 http://www.gentoo.org/proj/en/portage/doc/manually-fixing-portage.xml
8
9 The second document is referenced because no version of portage in the
10 library matches up with the version of python on this system. I've
11 followed the instructions and now portage seems to work except I see
12 this message which looks more like a warning than anything. Can I
13 safely ignore it?
14
15 myth11 ~ # emerge -pv system >>EmergeSystem.txt
16 !!! Problem with sandbox binary. Disabling...
17
18 !!! Problem with sandbox binary. Disabling...
19
20 myth11 ~ #
21
22
23 More important are some blocking issues. From the text file I saved in
24 the step above I have these blocks:
25
26
27 These are the packages that would be merged, in order:
28
29 Calculating system dependencies .^H^H... done!
30 [blocks B ] <dev-lang/python-2.3.6-r2 (is blocking
31 app-admin/python-updater-0.2)
32 [blocks B ] <sys-apps/util-linux-2.13 (is blocking
33 sys-apps/coreutils-6.10-r2)
34 [blocks B ] sys-apps/pam-login (is blocking sys-apps/shadow-4.0.18.2)
35
36
37 Are these blocks safe to remove? I assume they are system stuff and
38 hence the system might break.
39
40 thanks in advance,
41 Mark
42 --
43 gentoo-user@l.g.o mailing list

Replies

Subject Author
Re: [gentoo-user] Very old machine blocking/update questions Alan McKinnon <alan.mckinnon@×××××.com>