Gentoo Archives: gentoo-user

From: "John P. Burkett" <burkett@×××.edu>
To: gentoo-user@l.g.o
Subject: [gentoo-user] slot conflict
Date: Sun, 29 Mar 2009 06:26:48
Working on a amd64 machine, I did
emerge -D -uav world
and got the following response:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:


  ('installed', '/', 'dev-lang/python-2.5.2-r7', 'nomerge') pulled in by
    dev-lang/python required by ('installed', '/',
'dev-libs/libxslt-1.1.24-r1', 'nomerge')
    >=dev-lang/python-2.2 required by ('installed', '/',
'app-pda/libopensync-0.22', 'nomerge')
    dev-lang/python required by world
    (and 19 more)

  ('ebuild', '/', 'dev-lang/python-2.5.2-r7', 'merge') pulled in by
    >=dev-lang/python-2.3[-build,xml] required by ('ebuild', '/',
'app-text/iso-codes-3.6', 'merge')
    dev-lang/python required by world

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.

emerge: there are no ebuilds built with USE flags to satisfy
!!! One of the following packages is required to complete your request:
- app-text/poppler-bindings-0.10.4 (Change USE: +cairo)
(dependency required by "app-text/evince-2.24.2" [ebuild])
(dependency required by "world" [argument])

I would be grateful for suggestions as to (1) which package if any
should be masked, and (2) what to do about app-text/poppler-bindings.


John P. Burkett
Department of Economics
University of Rhode Island
Kingston, RI 02881-0808

phone (401) 874-9195


Subject Author
Re: [gentoo-user] slot conflict Alan McKinnon <alan.mckinnon@×××××.com>