Gentoo Archives: gentoo-user

From: Redouane Boumghar <redouane.boumghar@×××××××××.fr>
To: gentoo-user <gentoo-user@l.g.o>
Subject: [gentoo-user] Openssh and Zlib version check
Date: Mon, 23 Jun 2008 12:16:30
Message-Id: 485F942E.90706@magellium.fr
Hello everyone,

I am trying to upgrade openssh from version 4.5_p1 to version 4.7_p1
but installation of version 4.7_p1 always crashes at the zlib version check.

openssh 4.7_p1 seems to require zlib version 1.2.3 or greater
that I did have installed since the dinosaurs disappeared.
I keep having this message :

"
checking for possibly buggy zlib... yes
configure: error: *** zlib too old - check config.log ***
"

Whereas my zlib version is : 1.2.3
Installed thanks to ebuild : sys-libs/zlib-1.2.3-r1

So should I hack the ebuild to take the given advice  ? :

"./configure --without-zlib-version-check".

Has anyone solved that ? Or is it just my problem ?

Thanks in advance,

:-)
Redouane.

-- 
gentoo-user@l.g.o mailing list

Replies

Subject Author
Re: [gentoo-user] Openssh and Zlib version check Enrico Weigelt <weigelt@×××××.de>