Gentoo Archives: gentoo-user

From: fire-eyes <sgtphou@×××××××××.org>
To: gentoo-user@l.g.o
Subject: [gentoo-user] xorg-x11-7.0.0-r1: Can't load glx module with radeon driver
Date: Sun, 29 Jan 2006 17:33:48
Message-Id: 43DCFAC7.8040208@fire-eyes.org
Yee haw.

I'm using xorg-x11-7.0.0-r1. I am using their radeon driver, and trying
to get glx to load. It is my understanding that it now has 3d support (glx).

However when I try to start glxgears, I get this:

$ glxgears
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual


And the following in logs:

# grep -e "(WW)" -e "(EE)" /var/log/Xorg.0.log
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) Warning, couldn't open module glx
(EE) Failed to load module "glx" (module does not exist, 0)
(WW) RADEON(0): Failed to detect secondary monitor, MergedFB/Clone mode
disabled
(WW) RADEON(0): Enabling DRM support
(WW) RADEON(0): Direct rendering disabled
(WW) Couldn't load XKB keymap, falling back to pre-XKB keymap


So I don't really understand what's going on. Any ideas out there? I do
NOT want to continue using ati's own driver (fglrx), it is riddled with
problems. The whole reason I went to xorg 7 is because of it's new ati
drivers with 3d support.
-- 
gentoo-user@g.o mailing list

Replies

Subject Author
[gentoo-user] USER ERROR: xorg-x11-7.0.0-r1: Can't load glx module with radeon driver fire-eyes <sgtphou@×××××××××.org>
Re: [gentoo-user] xorg-x11-7.0.0-r1: Can't load glx module with radeon driver Richard Fish <bigfish@××××××××××.org>