Gentoo Archives: gentoo-user

From: Alexey Eschenko <skobkin-ru@××.ru>
To: gentoo-user@l.g.o
Subject: [gentoo-user] Strange problem with Ruby (vagrant)
Date: Wed, 20 Nov 2019 08:32:39
Message-Id: 5a5db76c-fe37-d7c9-2a69-e31a212316d0@ya.ru
Hi.

I need to use Vagrant but it doesn't work with strange error message:

> $ vagrant > Traceback (most recent call last): >         2: from > /usr/lib64/ruby/gems/2.6.0/gems/vagrant-2.2.6/bin/vagrant:88:in `<main>' >         1: from > /usr/lib64/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in > `require' > /usr/lib64/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in > `require': cannot load such file -- vagrant (LoadError) >         8: from > /usr/lib64/ruby/gems/2.6.0/gems/vagrant-2.2.6/bin/vagrant:88:in `<main>' >         7: from > /usr/lib64/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:34:in > `require' >         6: from > /usr/lib64/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:123:in > `rescue in require' >         5: from /usr/lib64/ruby/site_ruby/2.6.0/rubygems.rb:218:in > `try_activate' >         4: from > /usr/lib64/ruby/site_ruby/2.6.0/rubygems/specification.rb:1417:in > `activate' >         3: from > /usr/lib64/ruby/site_ruby/2.6.0/rubygems/specification.rb:1435:in > `activate_dependencies' >         2: from > /usr/lib64/ruby/site_ruby/2.6.0/rubygems/specification.rb:1435:in `each' >         1: from > /usr/lib64/ruby/site_ruby/2.6.0/rubygems/specification.rb:1446:in > `block in activate_dependencies' > /usr/lib64/ruby/site_ruby/2.6.0/rubygems/dependency.rb:313:in > `to_specs': Could not find 'rubyzip' (~> 1.2.2) - did find: > [rubyzip-2.0.0] (Gem::MissingSpecVersionError) > Checked in > 'GEM_PATH=/home/skobkin/.gem/ruby/2.6.0:/usr/lib64/ruby/gems/2.6.0:/usr/local/lib64/ruby/gems/2.6.0', > execute `gem env` for more information >         9: from > /usr/lib64/ruby/gems/2.6.0/gems/vagrant-2.2.6/bin/vagrant:88:in `<main>' >         8: from > /usr/lib64/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:34:in > `require' >         7: from > /usr/lib64/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:123:in > `rescue in require' >         6: from /usr/lib64/ruby/site_ruby/2.6.0/rubygems.rb:217:in > `try_activate' >         5: from /usr/lib64/ruby/site_ruby/2.6.0/rubygems.rb:224:in > `rescue in try_activate' >         4: from > /usr/lib64/ruby/site_ruby/2.6.0/rubygems/specification.rb:1417:in > `activate' >         3: from > /usr/lib64/ruby/site_ruby/2.6.0/rubygems/specification.rb:1435:in > `activate_dependencies' >         2: from > /usr/lib64/ruby/site_ruby/2.6.0/rubygems/specification.rb:1435:in `each' >         1: from > /usr/lib64/ruby/site_ruby/2.6.0/rubygems/specification.rb:1446:in > `block in activate_dependencies' > /usr/lib64/ruby/site_ruby/2.6.0/rubygems/dependency.rb:313:in > `to_specs': Could not find 'rubyzip' (~> 1.2.2) - did find: > [rubyzip-2.0.0] (Gem::MissingSpecVersionError) > Checked in > 'GEM_PATH=/home/skobkin/.gem/ruby/2.6.0:/usr/lib64/ruby/gems/2.6.0:/usr/local/lib64/ruby/gems/2.6.0', > execute `gem env` for more information
I'm calling it's strange because I have rubyzip package in my system (as said in error message).
> $ eix rubyzip > [I] dev-ruby/rubyzip >      Available versions:   >      (1)    1.2.2^t (~)1.2.3^t (~)1.2.4^t (~)1.3.0^t >      (2)    (~)2.0.0^t >        {test RUBY_TARGETS="ruby24 ruby25 ruby26"} >      Installed versions:  2.0.0(2)^t(01:44:09 PM 11/19/2019)(-test > RUBY_TARGETS="ruby26 -ruby24 -ruby25") >      Homepage:            https://github.com/rubyzip/rubyzip >      Description:         A ruby library for reading and writing zip files
I've decided that it's typical dependency problem and installed rubyzip-1.2.2. Then I've got new error:
> $ vagrant > Traceback (most recent call last): > <removed> > /usr/lib64/ruby/site_ruby/2.6.0/rubygems/specification.rb:2298:in > `raise_if_conflicts': Unable to activate vagrant_cloud-2.0.3, because > rest-client-2.1.0 conflicts with rest-client (~> 2.0.2) > (Gem::ConflictError) > <removed>
Then I've checked which packages require rest-client and got these:
> $ equery d rest-client >  * These packages depend on rest-client: > app-emulation/vagrant-2.2.6 (ruby_targets_ruby24 ? > dev-ruby/rest-client:2[ruby_targets_ruby24]) >                             (ruby_targets_ruby25 ? > dev-ruby/rest-client:2[ruby_targets_ruby25]) >                             (ruby_targets_ruby26 ? > dev-ruby/rest-client:2[ruby_targets_ruby26]) > dev-ruby/vagrant_cloud-2.0.3 (ruby_targets_ruby24 ? > >=dev-ruby/rest-client-2.0.2[ruby_targets_ruby24]) >                              (ruby_targets_ruby25 ? > >=dev-ruby/rest-client-2.0.2[ruby_targets_ruby25]) >                              (ruby_targets_ruby26 ? > >=dev-ruby/rest-client-2.0.2[ruby_targets_ruby26])
So I've removed rest-client-2.1.0 and installed 2.0.2. And then:
> $ > vagrant                                                                                                                                                                                                      >   > Traceback (most recent call last): > <removed> > /usr/lib64/ruby/site_ruby/2.6.0/rubygems/dependency.rb:311:in > `to_specs': Could not find 'ruby_dep' (>= 1.3.1) among 71 total gem(s) > (Gem::MissingSpecError) > Checked in > 'GEM_PATH=/home/skobkin/.gem/ruby/2.6.0:/usr/lib64/ruby/gems/2.6.0:/usr/local/lib64/ruby/gems/2.6.0', > execute `gem env` for more information > <removed>
So I want to ask if someone at all have working Vagrant installation on ~amd64 or it's just broken? -- Kind regards, Alexey Eschenko https://skobk.in/

Attachments

File name MIME type
signature.asc application/pgp-signature

Replies

Subject Author
Re: [gentoo-user] Strange problem with Ruby (vagrant) Paul Klos <gentoo@××××××××.nl>