Gentoo Archives: gentoo-user

From: Mick <michaelkintzios@×××××.com>
To: gentoo-user@l.g.o
Subject: [gentoo-user] Imagemagick downgrade?
Date: Sun, 10 Nov 2019 12:51:39
Message-Id: 1768695.xnhBsS6d66@localhost
Having re-synced portage it now asks me to keyword media-gfx/
inkscape-1.0_beta1 and once I do, portage wants to downgrade media-gfx/
imagemagick from the installed 7.0.8.67 to 6.9.10.67.

I'm not sure why imagemagick is asking to be downgraded, or for that matter 
why inkscape should be keyworded:

snip...

These are the packages that would be merged, in order:

Calculating dependencies... done!

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by @selected
# required by @world (argument)
=media-gfx/inkscape-1.0_beta1 ~amd64

Would you like to add these changes to your config files? [Yes/No] no

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.

!!! All ebuilds that could satisfy "<media-gfx/imagemagick-7:=[cxx]" have been 
masked.
!!! One of the following masked packages is required to complete your request:
- media-gfx/imagemagick-6.9.10.67::gentoo (masked by: backtracking: slot 
conflict)

(dependency required by "media-gfx/inkscape-1.0_beta1::gentoo[imagemagick,-
graphicsmagick]" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])



# eshowkw media-gfx/imagemagick
Keywords for media-gfx/imagemagick:
            |                               |   u             |  
            | a a   a     p           s r   |   n             |  
            | l m   r i   p   h m s   p i m | e u s           | r
            | p d a m a p c x p 6 3   a s i | a s l           | e
            | h 6 r 6 6 p 6 8 p 8 9 s r c p | p e o           | p
            | a 4 m 4 4 c 4 6 a k 0 h c v s | i d t           | o
------------+-------------------------------+-----------------+-------
  6.9.10.67 | + + + o + + + + + o ~ ~ + o ~ | 6 o 0/6.9.10.67 | gentoo
------------+-------------------------------+-----------------+-------
[I]7.0.8.67 | + + + + + + + + + o ~ ~ + o ~ | 6 o 0/7.0.8.67  | gentoo
------------+-------------------------------+-----------------+-------
       9999 | o o o o o o o o o o o o o o o | 6 o 0/9999      | gentoo


# eshowkw media-gfx/inkscape
Keywords for media-gfx/inkscape:
          |                               |   u   |  
          | a a   a     p           s r   |   n   |  
          | l m   r i   p   h m s   p i m | e u s | r
          | p d a m a p c x p 6 3   a s i | a s l | e
          | h 6 r 6 6 p 6 8 p 8 9 s r c p | p e o | p
          | a 4 m 4 4 c 4 6 a k 0 h c v s | i d t | o
----------+-------------------------------+-------+-------
[I]0.92.4 | o + ~ o o + + + ~ o o o o o o | 6 o 0 | gentoo
1.0_beta1 | o ~ o o o ~ ~ ~ ~ o o o o o o | 7 o   | gentoo

$ eix -l imagemagick

[I] media-gfx/imagemagick
     Available versions:  
            6.9.10.67 (0/6.9.10.67)^u	[X bzip2 corefonts cxx djvu fftw 
fontconfig fpx graphviz hdri heif jbig jpeg jpeg2k lcms lqr lzma opencl 
openexr openmp pango perl png postscript q32 q8 raw static-libs svg test tiff 
truetype webp wmf xml zlib]	["corefonts? ( truetype ) test? ( corefonts 
)"]
            7.0.8.67  (0/7.0.8.67)	[X bzip2 corefonts cxx djvu fftw fontconfig 
fpx graphviz hdri heif jbig jpeg jpeg2k lcms lqr lzma opencl openexr openmp 
pango perl png postscript q32 q8 raw static-libs svg test tiff truetype webp 
wmf xml zlib]	["corefonts? ( truetype ) test? ( corefonts )"]
       **   9999      (0/9999)*l	[X bzip2 corefonts cxx djvu fftw fontconfig 
fpx graphviz hdri heif jbig jpeg jpeg2k lcms lqr lzma opencl openexr openmp 
pango perl png postscript q32 q8 raw static-libs svg test tiff truetype webp 
wmf xml zlib]	["corefonts? ( truetype ) test? ( corefonts )"]
     Installed versions:  7.0.8.67(0/7.0.8.67)(21:15:16 11/10/19)(X bzip2 cxx 
hdri jpeg lcms openmp pango png svg tiff truetype xml zlib -corefonts -djvu -
fftw -fontconfig -fpx -graphviz -heif -jbig -jpeg2k -lqr -lzma -opencl -
openexr -perl -postscript -q32 -q8 -raw -static-libs -test -webp -wmf)
     Homepage:            https://www.imagemagick.org/
     Description:         A collection of tools and libraries for many image 
formats

$ eix -l inkscape
[U] media-gfx/inkscape
     Available versions:  
            0.92.4    ^t	[cdr dbus dia exif gnome imagemagick inkjar 
jpeg latex lcms nls openmp postscript spell static-libs visio wpg 
PYTHON_TARGETS="python2_7"]	["python_targets_python2_7"]
       (~)  1.0_beta1 ^t	[cdr dbus dia exif gnome graphicsmagick 
imagemagick inkjar jemalloc jpeg lcms nls openmp postscript spell static-libs 
svg2 visio wpg PYTHON_SINGLE_TARGET="python3_5 python3_6 python3_7" 
PYTHON_TARGETS="python3_5 python3_6 python3_7"]	["^^ ( 
python_single_target_python3_5 python_single_target_python3_6 
python_single_target_python3_7 ) python_single_target_python3_5? ( 
python_targets_python3_5 ) python_single_target_python3_6? ( 
python_targets_python3_6 ) python_single_target_python3_7? ( 
python_targets_python3_7 )"]
     Installed versions:  0.92.4^t(10:16:19 14/10/19)(cdr dbus exif 
imagemagick jpeg lcms nls openmp postscript spell -dia -gnome -inkjar -latex -
static-libs -visio -wpg PYTHON_TARGETS="python2_7")
     Homepage:            https://inkscape.org/
     Description:         SVG based generic vector-drawing program


Am I misreading portage's output above?
-- 
Regards,

Mick

Attachments

File name MIME type
signature.asc application/pgp-signature

Replies

Subject Author
[gentoo-user] Re: Imagemagick downgrade? Nikos Chantziaras <realnc@×××××.com>