Gentoo Archives: gentoo-user

From: "Prado
To: gentoo-user@l.g.o
Subject: RE: [gentoo-user] problem with 2 partition installation from gent oo minimal system
Date: Wed, 26 Mar 2008 16:58:21
Message-Id: 4E1FE4B75AB2494AB917C6A2D3CA235A104959D3@vistex22.arbor.visteon.com
1 I had this problem too... the problem was SCSI not being compiled in my
2 kernel alongside the SATA driver. Remember to ensure none of them are being
3 built into modules.
4
5 Renato Borges A. Prado
6 Product Engineer - Software Validation Team
7 Visteon Automotive Systems - MSX International
8 rprado@×××××××.com
9 +55 (11) 6465-9144
10
11 -----Original Message-----
12 From: Fei Liu [mailto:feiliu4@×××××.com]
13 Sent: quarta-feira, 26 de março de 2008 12:40
14 To: gentoo-user@l.g.o
15 Subject: [gentoo-user] problem with 2 partition installation from gentoo
16 minimal system
17
18 Hello Group, I spend a whole day trying to get this to work. Here is my
19 setup
20
21 /dev/sda1 / ext3 noatime 0 1
22 /dev/sda2 swap
23
24 grub is installed using the 'root (hd0,0)' and 'setup (hd0)', no problem.
25
26 emerge kernel-sources worked fine.
27
28 However everytime the system boots, it reports the VFS panic (no root
29 system found problem). The kernel has built in ext2 and ext3 support.
30 The error hint is to supply root option during boot, but my boot command
31 is this
32 kernel /boot/kernel root=/dev/sda1
33
34 Is there something missing that I didn't think of that's causing the
35 failures? I followed the steps outlined here:
36 http://www.gentoo.org/doc/en/gentoo-x86-quickinstall.xml
37
38 except I am using a 2 partition setup.
39
40 Fei
41 --
42 gentoo-user@l.g.o mailing list
43 --
44 gentoo-user@l.g.o mailing list