Gentoo Archives: gentoo-user

From: allan gottlieb <gottlieb@×××.edu>
To: gentoo-user@l.g.o
Subject: [gentoo-user] trouble with my normal emerge --update @world
Date: Sun, 02 Dec 2018 21:56:50
Message-Id: 87pnuj8uel.fsf@nyu.edu
On one of my stable amd64 systems, I just ran

 emerge --update --changed-use --with-bdeps=n --deep @world

and received a list of 65 packages to merge (many gnome).

The update completed and I was told

!!! existing preserved libs:
>>> package: dev-libs/libcdio-2.0.0-r1
* - /usr/lib64/libcdio.so.16 * - /usr/lib64/libcdio.so.16.0.0 * used by /usr/bin/libcdio-paranoia (dev-libs/libcdio-paranoia-0.93_p1) * used by /usr/lib64/libcdio_cdda.so.2.0.0 (dev-libs/libcdio-paranoia-0.93_p1) * used by /usr/lib64/libcdio_paranoia.so.2.0.0 (dev-libs/libcdio-paranoia-0.93_p1) * used by /usr/libexec/gvfsd-cdda (gnome-base/gvfs-1.32.2) Use emerge @preserved-rebuild to rebuild packages using these libraries When I ran emerge --pretend @preserved-rebuild I was told to run merge dev-qt/qtcore-5.11.1 which is ~amd64, which seems wrong. The full output is below. Can someone please explain what is happening. thanks, allan E6430 ~ # emerge --pretend @preserved-rebuild These are the packages that would be merged, in reverse order: Calculating dependencies... done! [ebuild R ] gnome-base/gvfs-1.32.2 [ebuild R ] dev-libs/libcdio-paranoia-0.93_p1 [nomerge ] gnome-base/gvfs-1.32.2 [nomerge ] sys-fs/udisks-2.7.4-r1 [nomerge ] sys-libs/libblockdev-2.14-r1 [nomerge ] dev-libs/volume_key-0.3.11 [nomerge ] app-crypt/gpgme-1.11.1 [nomerge ] dev-qt/qttest-5.9.6 [ebuild UD~] dev-qt/qtcore-5.9.6-r1 [5.11.1-r1] !!! Multiple package instances within a single package slot have been pulled !!! into the dependency graph, resulting in a slot conflict: dev-qt/qtcore:5 (dev-qt/qtcore-5.11.1-r1:5/5.11::gentoo, installed) pulled in by ~dev-qt/qtcore-5.11.1 required by (dev-qt/qtconcurrent-5.11.1:5/5.11::gentoo, installed) ^ ^^^^^^ (and 9 more with the same problem) (dev-qt/qtcore-5.9.6-r1:5/5.9::gentoo, ebuild scheduled for merge) pulled in by ~dev-qt/qtcore-5.9.6 required by (dev-qt/qttest-5.9.6:5/5.9::gentoo, installed) ^ ^^^^^ NOTE: Use the '--verbose-conflicts' option to display parents omitted above It may be possible to solve this problem by using package.mask to prevent one of those packages from being selected. However, it is also possible that conflicting dependencies exist such that they are impossible to satisfy simultaneously. If such a conflict exists in the dependencies of two different packages, then those packages can not be installed simultaneously. For more information, see MASKED PACKAGES section in the emerge man page or refer to the Gentoo Handbook. The following keyword changes are necessary to proceed: (see "package.accept_keywords" in the portage(5) man page for more details) # required by dev-qt/qttest-5.9.6::gentoo # required by app-crypt/gpgme-1.11.1::gentoo[qt5] # required by app-crypt/seahorse-3.20.0::gentoo # required by gnome-base/gnome-core-apps-3.24.2::gentoo # required by gnome-base/gnome-3.24.2::gentoo # required by @selected # required by @world (argument) =dev-qt/qtcore-5.9.6-r1 ~amd64 * In order to avoid wasting time, backtracking has terminated early * due to the above autounmask change(s). The --autounmask-backtrack=y * option can be used to force further backtracking, but there is no * guarantee that it will produce a solution. * IMPORTANT: 1 news items need reading for repository 'gentoo'. * Use eselect news read to view new items. E6430 ~ #

Replies

Subject Author
[gentoo-user] Re: trouble with my normal emerge --update @world nunojsilva@×××××××.pt