Gentoo Archives: gentoo-user

From: Alexander Puchmayr <alexander.puchmayr@×××××××.at>
To: gentoo-user@l.g.o
Subject: [gentoo-user] kstars and indilib
Date: Fri, 07 Dec 2018 22:36:56
Message-Id: 1761606.E7lZeoRKSI@prometheus
Hi there,

I tried to compile kstars with useflag indi, but the provided version in 
portage is too old:

[build.log from kstars]
-- Checking for module 'libindi'
--   Found libindi, version 1.6.0
-- INDI version 1.5.0 found in /usr/include/libindi, but at least version 
1.7.1 is required
-- INDI version 1.5.0 found in /usr/include/libindi, but at least version 
1.7.1 is required
-- Found INDI: /usr/lib/libindiclient.a, /usr/include/libindi

I have no idea why it pretends to find indi-1.5.0, when 1.6 is installed :-(
Version 1.6 is currently the only version in portage, which renders the useflag 
"indi" for kstars useless, as the resulting kstars binary does not support 
indi.

https://indilib.org/download/gentoo.html shows a way to add an overlay, but 
the repo proposed does not exist anymore.

Where do I find a ebuild for installing at least indilib-1.7.1?

Regards
	Alex

Replies

Subject Author
Re: [gentoo-user] kstars and indilib David Haller <gentoo@×××××××.de>