Gentoo Archives: gentoo-user

From: Peter Humphrey <peter@××××××××××××.uk>
To: gentoo-user@l.g.o
Subject: [gentoo-user] An odd blocker
Date: Mon, 03 Dec 2018 09:58:15
Message-Id: 1884414.5fQOeQMpI7@peak
Hello list,

I came across this today on my little Atom box:

[ebuild  N     ] dev-util/glib-utils-2.56.2::gentoo  PYTHON_SINGLE_TARGET="python3_6 -python3_5 (-python3_7)" PYTHON_TARGETS="python3_6 -python3_5 (-python3_7)" 7,854 KiB
[ebuild     U  ] dev-libs/glib-2.56.2:2::gentoo [2.52.3:2::gentoo] USE="mime xattr -dbus -debug (-fam) (-selinux) -static-libs -systemtap -test -utils" PYTHON_TARGETS="(-python2_7%*)" 0 KiB
[blocks b      ] <dev-libs/glib-2.56.2:2 ("<dev-libs/glib-2.56.2:2" is blocking dev-util/glib-utils-2.56.2)                                                                         

All appears to have gone smoothly, but I wonder why upgrading glib pulls in a
new glib-utils, then portage says one is blocking the other. I know it's not a
hard block, but still...

-- 
Regards,
Peter.

Replies

Subject Author
Re: [gentoo-user] An odd blocker Neil Bothwick <neil@××××××××××.uk>