Gentoo Archives: gentoo-user

From: John Campbell <jdc.rpv@×××.net>
To: gentoo-user@l.g.o
Subject: Re: [gentoo-user] is zfs no longer compatible with systemd?
Date: Thu, 08 Oct 2015 07:24:01
Message-Id: 561619FB.8090003@cox.net
On 10/07/2015 11:51 PM, covici@××××××××××.com wrote:
> In trying to emerge sysf-fs/zfs today I get the following > [ebuild R *] sys-fs/zfs-9999::gentoo USE="rootfs -bash-completion > -custom-cflags -debug (-kernel-builtin) -static-libs -test-suite" > PYTHON_TARGETS="python2_7 python3_4 -python3_3" 0 KiB > [blocks B ] >=sys-fs/udev-init-scripts-28 > (">=sys-fs/udev-init-scripts-28" is blocking sys-fs/zfs-9999) > > Total: 1 package (1 reinstall), Size of downloads: 0 KiB > Conflict: 1 block (1 unsatisfied) > > * Error: The above package list contains packages which cannot be > * installed at the same time on the same system. > > (sys-fs/zfs-9999:0/0::gentoo, ebuild scheduled for merge) pulled in by > sys-fs/zfs required by @selected > sys-fs/zfs > > (sys-fs/udev-init-scripts-30:0/0::gentoo, installed) pulled in by > >=sys-fs/udev-init-scripts-25 required by > (sys-apps/systemd-226-r1:0/2::gentoo, installed) > > > Am I reading this correctly, or is there a way to satisfy the block?
Just from your output and reading the ebuilds you can downgrade to udev-init-scripts-27

Replies

Subject Author
Re: [gentoo-user] is zfs no longer compatible with systemd? covici@××××××××××.com