Gentoo Archives: gentoo-user

From: Andrew MacKenzie <amackenz@×××××××.com>
To: gentoo-user@l.g.o
Subject: [gentoo-user] Sound issue - can't use /dev/dsp
Date: Thu, 30 Oct 2008 16:41:10
Message-Id: 20081030164103.GE18532@edespot.com
1 My MythTV Gentoo box has recently started having issues recording sound.
2 The TV tuner re-plays audio through the "mic" interface on my soundcard.
3 It has worked for months, but now MythTV can't read anything from /dev/dsp.
4
5 Any device that uses ALSA directly seems to work fine (like TVTime which
6 plays TV with audio just fine) - only those that rely on /dev/dsp seem to
7 have trouble. My simple test shows this:
8
9 # cat /dev/dsp > /dev/null
10 cat: /dev/dsp: Input/output error
11
12 This was run as root. Perms are fine:
13
14 crw-rw---- 1 root audio 14, 3 2008-10-03 08:56 /dev/dsp
15
16 Myth user is in audio group (always has been).
17
18 Has something changed in ALSA that I didn't catch? I don't see anything in
19 my logs or dmesg that shows a problem. My /etc/asound.conf is as follows:
20 pcm.nforce-hw {
21 type hw
22 card 0
23 }
24 pcm.!default {
25 type plug
26 slave.pcm "nforce"
27 }
28 pcm.nforce {
29 type dmix
30 ipc_key 1234
31 ipc_perm 0660
32 slave {
33 pcm "hw:0,0"
34 period_time 0
35 period_size 1024
36 buffer_size 4096
37 #rate 44100
38 rate 48000
39 }
40 }
41 ctl.nforce-hw {
42 type hw
43 card 0
44 }
45
46
47 I have tried without this asound.conf and see the same issue.
48
49 --
50 // Andrew MacKenzie | http://www.edespot.com
51 // GPG public key: http://www.edespot.com/~amackenz/public.key
52 // I've touch'd the highest point of all my greatness;
53 // And from that full meridian of my glory
54 // I haste now to my setting. I shall fall,
55 // Like a bright exhalation in the evening
56 // And no man see me more.
57 // -- Shakespeare

Replies

Subject Author
Re: [gentoo-user] Sound issue - can't use /dev/dsp Andrey Vul <andrey.vul@×××××.com>