Gentoo Archives: gentoo-user

From: "John P. Burkett" <burkett@×××.edu>
To: gentoo-user@l.g.o
Subject: [gentoo-user] emacs-common-gentoo-1[X] mask
Date: Sat, 28 Mar 2009 18:48:01
Message-Id: 49CE70DC.3070105@uri.edu
Starting March 14, whenever I have tried doing
emerge -D -uav system
the response has included
!!! All ebuilds that could satisfy
">=app-emacs/emacs-common-gentoo-1[X]" have been masked.

On my x86 box, the response adds
- app-emacs/emacs-common-gentoo-1.0 (masked by: ~x86 keyword)
On my amd64 machine, the equivalent line is
- app-emacs/emacs-common-gentoo-1.0 (masked by: ~amd64 keyword)

The dependency listing is as follows:
(dependency required by "app-editors/emacs-22.3-r2" [installed])
(dependency required by "app-emacs/po-mode-0.17" [installed])
(dependency required by "sys-devel/gettext-0.17" [installed])
(dependency required by "sys-devel/gcc-4.1.2" [installed])
(dependency required by "system" [argument])

Doing
emerge -D -uav world
elicits similar messages.

I'm not sure whether it would be safer to (a) emerge a masked version of
emacs-common-gentoo-1.0 or to (b) alter the dependency structure,
eliminating the requirement for emacs-common-gentoo-1.0.  Further, I am
not sure how to do either one.  Suggestions would be much appreciated.

John



-- 
John P. Burkett
Department of Economics
University of Rhode Island
Kingston, RI 02881-0808
USA

phone (401) 874-9195

Replies

Subject Author
Re: [gentoo-user] emacs-common-gentoo-1[X] mask Jorge Morais <please.no.spam.here@×××××.com>