Gentoo Archives: gentoo-user

From: John Covici <covici@××××××××××.com>
To: gentoo-user@l.g.o
Subject: [gentoo-user] after finally doing my emerge -e world successfully, my regular world update fails
Date: Fri, 22 Dec 2017 10:02:25
Message-Id: m3bmir9j2x.wl-covici@ccs.covici.com
Hi.  So, after two weeks, I finally got my emerge -e world finished.
Now  I was trying my regular world update with --deep, etc., but I get
an impossible situation.  It seems openrc is now blocking systemd, but
I apparently need both.

Here is the output from emerge.

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/systemd-236-r1:0/2::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/systemd[pam] required by (sys-auth/pambase-20150213-r1:0/0::gentoo, installed)
    >=sys-apps/systemd-209:0= required by (net-misc/networkmanager-1.10.0:0/0::gentoo, installed)
    sys-apps/systemd:0= required by (net-fs/samba-4.7.3:0/0::gentoo, installed)
    sys-apps/systemd:0/2= required by (sys-apps/dbus-1.12.2:0/0::gentoo, installed)
    sys-apps/systemd:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (sys-apps/systemd:0=[abi_x86_64(-)]) required by (media-sound/pulseaudio-11.1:0/0::gentoo, installed)
    sys-apps/systemd:0/2= required by (net-fs/samba-4.7.3:0/0::gentoo, installed)
    >=sys-apps/systemd-206:0/2= required by (gnome-base/gvfs-1.32.1:0/0::gentoo, installed)
    sys-apps/systemd required by (gnome-base/gnome-settings-daemon-3.24.3:0/0::gentoo, installed)
    sys-apps/systemd:0/2= required by (net-vpn/libreswan-3.22:0/0::gentoo, installed)
    sys-apps/systemd required by (net-print/cups-2.2.6:0/0::gentoo, installed)
    sys-apps/systemd required by (sys-apps/util-linux-2.31-r1:0/0::gentoo, installed)
    sys-apps/systemd:0= required by (dev-python/python-systemd-233:0/0::gentoo, installed)
    >=sys-apps/systemd-183:0/2= required by (gnome-base/gnome-session-3.24.1:0/0::gentoo, installed)
    sys-apps/systemd:0= required by (net-vpn/libreswan-3.22:0/0::gentoo, installed)
    >=sys-apps/systemd-186:0= required by (sys-apps/accountsservice-0.6.45:0/0::gentoo, installed)
    >=sys-apps/systemd-183:0= required by (gnome-base/gnome-session-3.24.1:0/0::gentoo, installed)
    >=sys-apps/systemd-31 required by (gnome-base/gnome-control-center-3.24.3:2/2::gentoo, installed)
    >=sys-apps/systemd-209 required by (sys-fs/udisks-2.7.5:2/2::gentoo, installed)
    sys-apps/systemd required by (dev-db/postgresql-10.1:10/10::gentoo, installed)
    sys-apps/systemd:0/2=[abi_x86_64(-)] required by (media-sound/pulseaudio-11.1:0/0::gentoo, installed)
    >=sys-apps/systemd-186:0/2= required by (sys-apps/accountsservice-0.6.45:0/0::gentoo, installed)
    sys-apps/systemd:0/2= required by (sys-auth/polkit-0.113-r4:0/0::gentoo, installed)
    sys-apps/systemd:= required by (dev-qt/qtcore-5.9.3:5/5.9::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-209:0/2= required by (net-misc/networkmanager-1.10.0:0/0::gentoo, installed)
    >=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-7:0/0::gentoo, installed)
    >=sys-apps/systemd-205:0= required by (sys-fs/lvm2-2.02.166-r2:0/0::gentoo, installed)
    >=sys-apps/systemd-44:0/2= required by (x11-misc/colord-1.3.4:0/2::gentoo, installed)
    sys-apps/systemd required by (net-vpn/openvpn-2.4.4:0/0::gentoo, installed)
    sys-apps/systemd required by (virtual/tmpfiles-0:0/0::gentoo, installed)
    >=sys-apps/systemd-183 required by (net-misc/modemmanager-1.6.4:0/1::gentoo, installed)
    sys-apps/systemd required by @selected
    sys-apps/systemd required by (sys-process/procps-3.3.12-r1:0/5::gentoo, installed)
    sys-apps/systemd required by (net-wireless/bluez-5.47-r1:0/3::gentoo, installed)
    sys-apps/systemd:= required by (net-nds/rpcbind-0.2.4-r1:0/0::gentoo, installed)
    sys-apps/systemd required by (app-admin/syslog-ng-3.13.2:0/0::gentoo, ebuild scheduled for merge)
    sys-apps/systemd:0/2= required by (dev-python/python-systemd-233:0/0::gentoo, installed)
    >=sys-apps/systemd-44:0= required by (x11-misc/colord-1.3.4:0/2::gentoo, installed)
    sys-apps/systemd:0= required by (sys-apps/dbus-1.12.2:0/0::gentoo, installed)
    >=sys-apps/systemd-217:0 required by (virtual/udev-217:0/0::gentoo, installed)
    >=sys-apps/systemd-206:0= required by (gnome-base/gvfs-1.32.1:0/0::gentoo, installed)
    >=sys-apps/systemd-205:0/2= required by (sys-fs/lvm2-2.02.166-r2:0/0::gentoo, installed)
    sys-apps/systemd:0/2= required by (net-nds/rpcbind-0.2.4-r1:0/0::gentoo, installed)
    >=sys-apps/systemd-212-r5:0/2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-apps/systemd-212-r5:0/2[abi_x86_32(-),abi_x86_64(-)]) required by (virtual/libudev-232:0/1::gentoo, installed)
    sys-apps/systemd:0= required by (sys-auth/polkit-0.113-r4:0/0::gentoo, installed)
    sys-apps/systemd required by (x11-base/xorg-server-1.19.5:0/1.19.5::gentoo, installed)

  (sys-apps/sysvinit-2.88-r9:0/0::gentoo, installed) pulled in by
    >=sys-apps/sysvinit-2.86-r6[selinux?] (>=sys-apps/sysvinit-2.86-r6) required by (sys-apps/openrc-0.34.11:0/0::gentoo, installed)
    >=sys-apps/sysvinit-2.87-r3 required by (sys-kernel/dracut-046:0/0::gentoo, installed)


I certainly need dracut and possibly other pieces, so how do I resolve
this one?

Any assistance would be appreciated.

-- 
Your life is like a penny.  You're going to lose it.  The question is:
How do
you spend it?

         John Covici wb2una
         covici@××××××××××.com

Replies