Gentoo Archives: gentoo-user

From: Hubert Hauser <hubot@××××.com>
To: gentoo-user@l.g.o
Subject: Re: Re: [gentoo-user] gst-plugins-bad-1.11.90 is blocking gst-plugins-base-1.12.3
Date: Tue, 17 Oct 2017 17:36:48
Message-Id: 2212dd4d-6daf-60a3-bbbd-6f36dff3dbe9@mail.com
Now I've an error:

tux ~ # emerge --verbose-conflicts @preserved-rebuild

 * IMPORTANT: 8 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Calculating dependencies... done!
[ebuild   R    ] dev-libs/botan-1.10.17
[ebuild     U  ] media-gfx/imagemagick-7.0.7.6 [6.9.9.0]
[ebuild   R    ] dev-python/pillow-4.2.1-r1
[ebuild     U  ] dev-qt/qtgui-5.9.2 [5.7.1-r1] USE="libinput* -vnc%"
[ebuild   R    ] media-video/ffmpeg-3.3.4
[ebuild     U  ] dev-qt/qtwidgets-5.9.2 [5.7.1] USE="gtk%*"
[ebuild     U  ] media-libs/gst-plugins-ugly-1.12.3 [1.10.5]
[ebuild     U  ] dev-qt/qtdeclarative-5.9.2 [5.7.1]
[ebuild     U  ] dev-qt/qtprintsupport-5.9.2 [5.7.1]
[ebuild     U  ] media-plugins/gst-plugins-x264-1.12.3 [1.10.5]
[ebuild     U  ] media-video/vlc-2.2.6-r2 [2.2.6] USE="qt5*"
[ebuild     U  ] dev-qt/qtwebchannel-5.9.2 [5.7.1]
[ebuild   R    ] net-analyzer/wireshark-2.4.2
[ebuild     U  ] xfce-base/xfwm4-4.13.0-r1 [4.12.3-r1] USE="opengl%*
-xpresent%"
[ebuild     U  ] app-editors/vim-8.0.1188 [8.0.0386] USE="terminal%*"
PYTHON_SINGLE_TARGET="python3_4%* -python2_7% -python3_5% -python3_6%"
[ebuild     U  ] dev-qt/qtwebengine-5.9.2 [5.7.1-r2]
[ebuild   R    ] dev-db/postgresql-9.6.5-r1
[ebuild     U  ] media-video/obs-studio-20.0.1-r1 [20.0.1]
[ebuild     U  ] net-print/cups-filters-1.17.9 [1.16.4] USE="-pclm%"
[ebuild     U  ] media-gfx/graphviz-2.40.1 [2.38.0-r1]
[ebuild   R    ] www-servers/nginx-1.12.1
[ebuild   R    ] dev-lang/php-7.0.24
[ebuild   R    ] dev-db/mariadb-10.2.9

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtgui:5

  (dev-qt/qtgui-5.7.1-r1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtgui-5.7.1 required by
(dev-qt/qtwebkit-5.7.1:5/5.7::gentoo, installed)
    ^            
^^^^^                                                                                                                   

    ~dev-qt/qtgui-5.7.1[gles2=] required by
(dev-qt/qtopengl-5.7.1:5/5.7::gentoo, installed)
    ^            
^^^^^                                                                                                                           

    ~dev-qt/qtgui-5.7.1 required by (dev-qt/qthelp-5.7.1:5/5.7::gentoo,
installed)
    ^            
^^^^^                                                                                                                 

    ~dev-qt/qtgui-5.7.1[gles2=] required by
(dev-qt/qtprintsupport-5.7.1:5/5.7::gentoo, installed)
    ^            
^^^^^                                                                                                                                 

    ~dev-qt/qtgui-5.7.1 required by
(dev-qt/qtquickcontrols-5.7.1:5/5.7::gentoo, installed)
    ^            
^^^^^                                                                                                                          

    ~dev-qt/qtgui-5.7.1[gles2=] required by
(dev-qt/qtmultimedia-5.7.1:5/5.7::gentoo, installed)
    ^            
^^^^^                                                                                                                               

    ~dev-qt/qtgui-5.7.1[gles2=,png=,xcb?] required by
(dev-qt/qtwidgets-5.7.1:5/5.7::gentoo, installed)
    ^            
^^^^^                                                                                                                                      

    ~dev-qt/qtgui-5.7.1[gles2=] required by
(dev-qt/qtdeclarative-5.7.1:5/5.7::gentoo, installed)
    ^            
^^^^^                                                                                                                                

    ~dev-qt/qtgui-5.7.1 required by (dev-qt/qtsvg-5.7.1:5/5.7::gentoo,
installed)
    ^            
^^^^^                                                                                                                

    ~dev-qt/qtgui-5.7.1[xcb] required by
(dev-qt/qtx11extras-5.7.1:5/5.7::gentoo, installed)
    ^            
^^^^^                                                                                                                           



  (dev-qt/qtgui-5.9.2:5/5.9::gentoo, ebuild scheduled for merge) pulled
in by
    ~dev-qt/qtgui-5.9.2[gles2=,png=,xcb?] required by
(dev-qt/qtwidgets-5.9.2:5/5.9::gentoo, ebuild scheduled for merge)
    ^            
^^^^^                                                                                                                                                       

    ~dev-qt/qtgui-5.9.2[gles2=] required by
(dev-qt/qtdeclarative-5.9.2:5/5.9::gentoo, ebuild scheduled for merge)
    ^            
^^^^^                                                                                                                                                 

    ~dev-qt/qtgui-5.9.2 required by
(dev-qt/qtwebengine-5.9.2:5/5.9::gentoo, ebuild scheduled for merge)
    ^            
^^^^^                                                                                                                                       

    ~dev-qt/qtgui-5.9.2[gles2=] required by
(dev-qt/qtprintsupport-5.9.2:5/5.9::gentoo, ebuild scheduled for merge)
    ^            
^^^^^                                                                                                                                                  


dev-qt/qtprintsupport:5

  (dev-qt/qtprintsupport-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtprintsupport-5.7.1 required by
(dev-qt/qtwebkit-5.7.1:5/5.7::gentoo, installed)
    ^                     
^^^^^                                                                                                                   


  (dev-qt/qtprintsupport-5.9.2:5/5.9::gentoo, ebuild scheduled for
merge) pulled in by
    ~dev-qt/qtprintsupport-5.9.2 required by
(dev-qt/qtwebengine-5.9.2:5/5.9::gentoo, ebuild scheduled for merge)
    ^                     
^^^^^                                                                                                                                       


dev-qt/qtwidgets:5

  (dev-qt/qtwidgets-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtwidgets-5.7.1[gles2=] required by
(dev-qt/qtdeclarative-5.7.1:5/5.7::gentoo, installed)
    ^                
^^^^^                                                                                                                                

    ~dev-qt/qtwidgets-5.7.1 required by
(dev-qt/qtquickcontrols-5.7.1:5/5.7::gentoo, installed)
    ^                
^^^^^                                                                                                                          

    ~dev-qt/qtwidgets-5.7.1[gles2=] required by
(dev-qt/qtopengl-5.7.1:5/5.7::gentoo, installed)
    ^                
^^^^^                                                                                                                           

    ~dev-qt/qtwidgets-5.7.1 required by
(dev-qt/qtsvg-5.7.1:5/5.7::gentoo, installed)
    ^                
^^^^^                                                                                                                

    ~dev-qt/qtwidgets-5.7.1 required by
(dev-qt/qthelp-5.7.1:5/5.7::gentoo, installed)
    ^                
^^^^^                                                                                                                 

    ~dev-qt/qtwidgets-5.7.1[gles2=] required by
(dev-qt/qtprintsupport-5.7.1:5/5.7::gentoo, installed)
    ^                
^^^^^                                                                                                                                 

    ~dev-qt/qtwidgets-5.7.1 required by
(dev-qt/qtwebkit-5.7.1:5/5.7::gentoo, installed)
    ^                
^^^^^                                                                                                                   


  (dev-qt/qtwidgets-5.9.2:5/5.9::gentoo, ebuild scheduled for merge)
pulled in by
    ~dev-qt/qtwidgets-5.9.2[gles2=] required by
(dev-qt/qtprintsupport-5.9.2:5/5.9::gentoo, ebuild scheduled for merge)
    ^                
^^^^^                                                                                                                                                  

    ~dev-qt/qtwidgets-5.9.2[gles2=] required by
(dev-qt/qtdeclarative-5.9.2:5/5.9::gentoo, ebuild scheduled for merge)
    ^                
^^^^^                                                                                                                                                 

    ~dev-qt/qtwidgets-5.9.2 required by
(dev-qt/qtwebengine-5.9.2:5/5.9::gentoo, ebuild scheduled for merge)
    ^                
^^^^^                                                                                                                                       


dev-qt/qtdeclarative:5

  (dev-qt/qtdeclarative-5.9.2:5/5.9::gentoo, ebuild scheduled for merge)
pulled in by
    ~dev-qt/qtdeclarative-5.9.2 required by
(dev-qt/qtwebengine-5.9.2:5/5.9::gentoo, ebuild scheduled for merge)
    ^                    
^^^^^                                                                                                                                       

    ~dev-qt/qtdeclarative-5.9.2 required by
(dev-qt/qtwebchannel-5.9.2:5/5.9::gentoo, ebuild scheduled for merge)
    ^                    
^^^^^                                                                                                                                        

  (dev-qt/qtdeclarative-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtdeclarative-5.7.1 required by
(dev-qt/qtquickcontrols-5.7.1:5/5.7::gentoo, installed)
    ^                    
^^^^^                                                                                                                          



It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- app-admin/keepassx-2.0.2-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Lars Wendler <polynomial-c@g.o> (12 Oct 2017)
# Dead upstream. No qt5 release. Use app-admin/keepassxc as drop-in
# replacement which has very active upstream and regular releases.
# Masked for removal in 30 days.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

Can you help me?