Gentoo Archives: gentoo-user

From: JM <jmurray315@××××××××××.com>
To: gentoo-user@l.g.o
Subject: Re: [gentoo-user] Problem with python-updater ?
Date: Sun, 27 Mar 2011 19:21:00
Message-Id: AANLkTimbf6XBwkXk8hC3iVgaiYTdWfsB-_Ro4ndHmmSn@mail.gmail.com
In Reply to: Re: [gentoo-user] Problem with python-updater ? by Dale
1 I would look at python 3 - I couldn't emerge until only 2.6 was active. I
2 don't know how but on the new machine I set up, python3 was selected as
3 active, I set it back to 2.6 and everything was fine. From the output I can
4 see there is a version of python 3 active. Maybe a red herring, if so, I
5 apologies :)
6
7 When I had the problem I went on irc and it was suggested that I do a
8 revdep-rebuild which I did also.
9
10
11
12 On 25 March 2011 16:42, Dale <rdalek1967@×××××.com> wrote:
13
14 > Jacques Montier wrote:
15 >
16 >> Hi all,
17 >>
18 >> I upgraded python2.6 to python2.7,
19 >> then i run eselect python set python2.7,
20 >> then python-updater.
21 >>
22 >> Here is the python-updater output :
23 >>
24 >> * Starting Python Updater...
25 >> * Main active version of Python: 2.7
26 >> * Active version of Python 2: 2.7
27 >> * Active version of Python 3: 3.1
28 >> * Adding to list: app-emulation/emul-linux-x86-baselibs:0
29 >> * Adding to list: app-emulation/virtualbox-bin:0
30 >> * Adding to list: app-office/libreoffice-bin:0
31 >> * Adding to list: dev-libs/boost:1.42
32 >> * check: manual [Added to list manually, see CHECKS in manpage for
33 >> more information.]
34 >> * Adding to list: sys-libs/tdb:0
35 >> * Adding to list: x11-libs/vte:0
36 >> * check: manual [Added to list manually, see CHECKS in manpage for
37 >> more information.]
38 >> * emerge -Dv1 --keep-going app-emulation/emul-linux-x86-baselibs:0
39 >> app-emulation/virtualbox-bin:0 app-office/libreoffice-bin:0
40 >> dev-libs/boost:1.42 sys-libs/tdb:0 x11-libs/vte:0
41 >> ...............................
42 >> Ok, everything emerge fine.
43 >>
44 >> If i run python-updater again, then i get exactly the same output as
45 >> before (emerging emul-linux-x86-baselibs:0, BOOST:1.42, etc...)
46 >>
47 >> What's wrong ??
48 >>
49 >> Thanks
50 >>
51 >>
52 >>
53 >
54 > That seems a bit odd but it depends on what you have installed. I have KDE
55 > on mine and it is in the process of rebuilding a little over 50 packages.
56 > Most of them are small except for OOo. Natuarally when anything gets
57 > updated that monster has to be recompiled. lol If you have KDE, I would
58 > think it would rebuild more than that. Also, it seems most of mine is
59 > @system packages. I would not reboot or logout yet just to be safe.
60 >
61 > Anyone notice it wants to rebuild a binary on the OPs system? Hmmm.
62 >
63 > Dale
64 >
65 > :-) :-)
66 >
67 >