Gentoo Archives: gentoo-user

From: Hung Dang <hungptit@×××××.com>
To: Gentoo-user <gentoo-user@l.g.o>
Subject: [gentoo-user] Cannot emerge gnome because openssl's bindist use flag
Date: Sun, 14 Jan 2018 14:51:12
Message-Id: 8891f2c8-81f9-632f-c299-48786696d27a@gmail.com
I cannot emerge gnome in a fresh build ~amd64 system. Basically, if I 
enable bindist use flag for openssl then emerge will ask me to disable 
it. However, if I disable bindist flag for openssl then it will ask me 
to enable it. How can I break this dependency loop?

Thanks,
Hung

Below is the the output of emerge -pv --update --deep --newuse 
--backtrack=100 world

* use gnome/systemd profile

The following USE changes are necessary to proceed:
(see "package.use" in the portage(5) man page for more details)
# required by dev-python/m2crypto-0.27.0::gentoo[-libressl]
# required by net-wireless/crda-3.18-r1::gentoo
# required by net-wireless/wpa_supplicant-2.6-r4::gentoo
# required by net-misc/networkmanager-1.10.2::gentoo[wifi]
# required by gnome-base/gnome-control-center-3.24.3::gentoo[networkmanager]
# required by net-libs/gnome-online-accounts-3.24.4::gentoo[gnome]
# required by gnome-base/gvfs-1.32.1-r1::gentoo[google]
# required by sci-geosciences/geocode-glib-3.24.0::gentoo
# required by dev-libs/libgweather-3.24.1::gentoo
# required by gnome-base/gnome-settings-daemon-3.24.3::gentoo
# required by gnome-base/gnome-session-3.24.2::gentoo
>=dev-libs/openssl-1.0.2n -bindist
* In order to avoid wasting time, backtracking has terminated early * due to the above autounmask change(s). The --autounmask-backtrack=y * option can be used to force further backtracking, but there is no * guarantee that it will produce a solution. * Use >=dev-libs/openssl-1.0.2n -bindist The following USE changes are necessary to proceed: (see "package.use" in the portage(5) man page for more details) # required by net-misc/openssh-7.6_p1-r1::gentoo[-libressl,ssl,-static] # required by gnome-base/gvfs-1.32.1-r1::gentoo # required by sci-geosciences/geocode-glib-3.24.0::gentoo # required by dev-libs/libgweather-3.24.1::gentoo # required by gnome-base/gnome-settings-daemon-3.24.3::gentoo # required by gnome-base/gnome-control-center-3.24.3::gentoo # required by net-libs/gnome-online-accounts-3.24.4::gentoo[gnome] # required by dev-libs/libgdata-0.17.9-r1::gentoo[gnome-online-accounts]
>=dev-libs/openssl-1.0.2n bindist

Replies