Gentoo Archives: gentoo-dev

From: Thomas Sachau <tommy@g.o>
To: gentoo-dev@l.g.o
Subject: Re: [gentoo-dev] Packages pulling in python-3*, also they dont require it
Date: Thu, 18 Mar 2010 19:44:08
Message-Id: 4BA28262.4070108@gentoo.org
In Reply to: Re: [gentoo-dev] Packages pulling in python-3*, also they dont require it by Ciaran McCreesh
On 03/18/2010 08:28 PM, Ciaran McCreesh wrote:
> On Thu, 18 Mar 2010 20:20:02 +0100 > Thomas Sachau <tommy@g.o> wrote: >> -change portage behaviour to be satisfied with a python slot and to >> not require other slots. > > But then you'll never get new slots for the majority of dependencies > where you do usually want the newest version. If Portage were to take > existing slots, most users would still be using Python 2.4 to > satisfy dependencies, and would never have had 2.5+ installed... >
I know this part, this option was just the result of Arfrever telling me that just "dev-lang/python" is the right dependency and the PM being wrong, when pulling in something unneeded. python-3* might be a special case, since it is incompactible with 2* versions and wont be set as the default python during install. But this results in it being useless and not needed, until either a package or a user does require it explicitly. So my vote goes for changing the dependency strings for affected packages. -- Thomas Sachau Gentoo Linux Developer

Attachments

File name MIME type
signature.asc application/pgp-signature

Replies

Subject Author
Re: [gentoo-dev] Packages pulling in python-3*, also they dont require it "Petteri R├Ąty" <betelgeuse@g.o>