Gentoo Archives: gentoo-dev

From: Ulrich Mueller <ulm@g.o>
To: gentoo-dev@l.g.o
Subject: Re: [gentoo-dev] Pending removal(?) of media-libs/pdflib
Date: Tue, 22 Feb 2011 07:30:29
Message-Id: 19811.26050.482587.875149@a1i15.kph.uni-mainz.de
In Reply to: [gentoo-dev] Pending removal(?) of media-libs/pdflib by Jeremy Olexa
>>>>> On Mon, 21 Feb 2011, Jeremy Olexa wrote:
> The bugs are stacking up[1] and upstream only offers a paid version of > pdflib-8[2]. It is my understanding that there is no way for us to > package future versions and the bundled libs are vulnerable[3].
> So, should it be removed? For more info, see the tracker bug for its > removal[1], there are a number of rdeps that will require fixing[4].
sci-visualization/gnuplot[pdf] is currently linking against pdflib. I'm going to remove that dependency, because in my understanding, clause 2.1 of the PDFLite license does not allow such linking. (It allows it for programs under an OSI approved license. However, the gnuplot license is free, but not OSI approved.) Ulrich

Replies

Subject Author
Re: [gentoo-dev] Pending removal(?) of media-libs/pdflib Mike Frysinger <vapier@g.o>