Gentoo Archives: gentoo-pms

From: Ulrich Mueller <ulm@g.o>
To: "Petteri Räty" <betelgeuse@g.o>
Cc: gentoo-pms@l.g.o
Subject: Re: [gentoo-pms] Clarification of has_version cat/pkg[use=] behavior for EAPI 3 or 4
Date: Sat, 12 Sep 2009 19:46:16
Message-Id: 19115.64128.823485.410000@a1i15.kph.uni-mainz.de
In Reply to: Re: [gentoo-pms] Clarification of has_version cat/pkg[use=] behavior for EAPI 3 or 4 by "Petteri Räty"
>>>>> On Sat, 12 Sep 2009, Petteri Räty wrote: > Ciaran McCreesh wrote: >> Well, I still think it's horrible (and I think the same about >> pretty much anything else using has_version...), but I can't come >> up with any creative way of interpreting PMS to say that it >> *should* be illegal... So if we're making a change, it's a >> retroactive one to work around a Portage bug...
> Going with it being a Portage bug is fine by me.
+1 Changing PMS seems unnatural in this case. Why should the USE flag syntax for has_version be different from the one in dependencies? Ulrich