Gentoo Archives: gentoo-pms

From: "Petteri Räty" <betelgeuse@g.o>
To: gentoo-pms@l.g.o
Subject: Re: [gentoo-pms] Clarification of has_version cat/pkg[use=] behavior for EAPI 3 or 4
Date: Sat, 12 Sep 2009 18:39:47
Message-Id: 4AABEAE7.8090503@gentoo.org
In Reply to: Re: [gentoo-pms] Clarification of has_version cat/pkg[use=] behavior for EAPI 3 or 4 by Ciaran McCreesh
Ciaran McCreesh wrote:
> On Sat, 12 Sep 2009 21:13:06 +0300 > Petteri Räty <betelgeuse@g.o> wrote: >> tove was trying to use it for perl: >> http://git.overlays.gentoo.org/gitweb/?p=proj/perl-overlay.git;a=commitdiff_plain;h=1a4be047e0ad2f13a7eeab9a5295557023ef2d62 > > Well, I still think it's horrible (and I think the same about pretty > much anything else using has_version...), but I can't come up with any > creative way of interpreting PMS to say that it *should* be illegal... > So if we're making a change, it's a retroactive one to work around a > Portage bug... > > *shrug* I have no strong opinion on how we handle it. >
At least has_version is an improvement over built_with_use. Going with it being a Portage bug is fine by me. Regards, Petteri

Replies