Gentoo Archives: gentoo-science

From: rose@××××××××××××××.de
To: gentoo-science@l.g.o
Subject: Re: [gentoo-science] sci-mathematics/sage-4.7.1-r2 still circumvents the installation of numpy > numpy-1.5.1
Date: Sun, 09 Oct 2011 23:21:47
Message-Id: 20111010012125.9fo894ks0048s0wg@webmail.uni-potsdam.de
In Reply to: Re: [gentoo-science] sci-mathematics/sage-4.7.1-r2 still circumvents the installation of numpy > numpy-1.5.1 by fbissey@slingshot.co.nz
Quoting fbissey@××××××××××××.nz:

> Quoting rose@××××××××××××××.de: > >> The installation of scipy-0.9.0-r2 is blocked by sage-4.7.1-r2, >> because 'emerge scipy' fails if numpy-1.5.1 and not numpy-1.6.1-r1 is >> installed. But the installation of numpy-1.6.1-r1 is blocked by >> sage-4.7.1-r2: >> >> root@impala:/root(2)# emerge -pvuDN world >> These are the packages that would be merged, in order: >> Calculating dependencies... done! >> [ebuild U ] sci-libs/scipy-0.9.0-r2 [0.9.0-r1] USE="doc -umfpack" 0 kB >> Total: 1 package (1 upgrade), Size of downloads: 0 kB >> WARNING: One or more updates have been skipped due to a dependency conflict: >> dev-python/numpy:0 >> (dev-python/numpy-1.6.1-r1::gentoo, ebuild scheduled for merge) >> conflicts with >> ~dev-python/numpy-1.5.1 required by >> (sci-mathematics/sage-4.7.1-r2::sage-on-gentoo, installed) >> dev-python/pexpect:0 >> (dev-python/pexpect-2.4-r1::sage-on-gentoo, ebuild scheduled for >> merge) conflicts with >> ~dev-python/pexpect-2.0 required by >> (sci-mathematics/sage-4.7.1-r2::sage-on-gentoo, installed) >> >> The restriction to numpy-1.5.1 was motivated with missing clapack_* >> symbols corresonding to Bug >> https://bugs.gentoo.org/show_bug.cgi?id=371099. >> >> But this issue seems to be solved now, comment 40 to Bug 371099. > > I am not sure I understand your email fully. scipy-0.9.0-r2 doesn't require > numpy-1.6.1. > Indeed you cannot upgrade numpy to 1.6.1 but that doesn't prevent the > merging of > anything. It is just a version constraint. It is unfortunate but that's > the way > it is. > > Do you absolutely need numpy-1.6 for something else than sage? > > Francois
Hi Francois, it seems, that scipy-0.9.0-r2 fails to emerge if numpy-1.5.1 is installed but it is emerged if numpy-1.6.1-r1, compare Bug 386269 https://bugs.gentoo.org/show_bug.cgi?id=386269 . Regards Juergen

Replies