Gentoo Archives: gentoo-user-br

From: angico <angico@×××××.com>
To: gentoo-user-br@l.g.o
Subject: Re: Aviso (era -> Re: [gentoo-user-br] nvidia no gentoo não cria os nodes em /dev)
Date: Sat, 17 Sep 2005 10:59:39
Message-Id: 20050917105900.45831.qmail@web30815.mail.mud.yahoo.com
In Reply to: Re: Aviso (era -> Re: [gentoo-user-br] nvidia no gentoo não cria os nodes em /dev) by Magno Torres
tô acompanhando a discussão de fora, mas concordo plenamente com o
magno. acho que o objetivo da lista é ajuda mútua, não descarga
emocional de frustrados...
angico.


--- Magno Torres <magnotorres@×××××.com> wrote:

> Eu iria esperar mais 2 dias pra ver se passava a TPM. ;) > Tentei ajudar, nao pisei no pé de ninguem apenas fiz um comentario > justo. > Dei a minha sugestão e disse numa boa que um projeto GPL nao precisa > dar > suporte a um outro fechado, é uma verdade absoluta, nao era pra pisar > em > ninguem. > > Se ela disse que ja havia sugerido isto, otimo, foi mancada minha > responder > o que ja havia sido reportado, mas mantenho o que disse. Não era pra > se > ofender, nem disse isso pra ela, disse pra lista, pra pensarmos mais > antes > de querermos tudo de bandeja, mesmo o udev sendo uma maravilha não > tem que > se adaptar a um projeto fechado o contrario é que tem de ser feito. > O proprio kernel fica tainted quando se adiciona um modulo fechado > como o do > vmware e nem adianta pedir suporte, pq o kernel está pichado :) > Ela poderia ter respondido que ja estava careca de saber o que eu > disse, e > pronto. Como eu assumi, cai de paraquedas. Iria ficar nisso nao fosse > a > patada, o que me arremeteu a tirar um sarro basico > Vou dar um puxão de orelha, pq se alguem tenta ajudar e leva uma > patada > dessas, ai respondo com um beliscão, acho justo, tb acho justo ser > moderado > por isso, só não acho justo pagar o pato sozinho. Não é por ser > mulher que > vai ter a minha piedade ;) > E chega desse papo besta que hoje é sexta feira, e já to indo pro > boteco, > tomar a minha gelada e pegar a minha mina ;) > > flames > /dev/magno 2>&1 > > > Em 16/09/05, Otavio R. Piske <angusyoung@g.o> escreveu: > > > > Gente, vamos acalmar nossos ânimos ok? > > > > Dito isto vamos deixar algumas coisas bem claras para todos nós: > > - Esta lista não tem espaço para piadinhas preconceituosas de > qualquer > > *tipo*. > > - Idem para flames em geral. > > > > Se eu voltar a acompanhar eu não vou hesitar em reportar para os > > responsáveis pela infra-estrutura do projeto para que tomem as > devidas > > precauções. > > > > Magno: suas colocações foram *bastante* infelizes ... Pelo menos > até > > aonde tenho acompanhado, sua participação na lista é muito melhor > do que > > essa que deixou transparecer nas últimas duas mensagens. > > > > Nat: sei que é complicado se segurar quando "pisam no nosso pé", > mas > > procure se acalmar quando essas coisas acontecerem. > > > > Por fim, qualquer pessoal que tenha problema na lista pode abrir um > bug > > report no projeto (em inglês) ou então entrar em contato > diretamente > > comigo. Meus emails estão a disposição de qualquer um que queira > relatar > > algum problema. > > > > Atenciosamente > > Otavio R. Piske - AngusYoung > > > > On Fri, 2005-09-16 at 15:12 -0300, Magno Torres wrote: > > > Vou esperar mais 2 dias ;) > > > > > > Em 15/09/05, Renata Romanazzi <natzilla@×××××.com> escreveu: > > > Não, você nasceu no século errado, é um pouco pior. > > > > > > On 9/15/05, Magno Torres <magnotorres@×××××.com> wrote: > > > > Opz, cai de paraquedas e respondi no dia errado ;) > > > > > > > > > > > > Em 15/09/05, Renata Romanazzi < natzilla@×××××.com> > > > escreveu: > > > > > > > > > > Caro Magno: > > > > > > > > > > Eu ESCREVI que o arquivo de rules do Udev tem as regras > > > pra criar os > > > > > devices da nvidia. > > > > > > > > > > E se você não percebeu, eu estava fazendo uma PIADA quando > > > disse que o > > > > > udev tinha que tomar vergonha - afinal, um programa não > > > pode "tomar > > > > > vergonha" porque não é uma pessoa, certo? > > > > > > > > > > Eu estou tentando descobrir porque APESAR de estar com as > > > regras e o > > > > > modulo carregado, os devices não sao criados, ok? > > > > > > > > > > Oh, céus... eu devo merecer. > > > > > > > > > > On 9/15/05, Magno Torres < magnotorres@×××××.com> wrote: > > > > > > Renata, > > > > > > > > > > > > Se quer que o udev faça as coisas "sozinho" precisa > > > editar seu arquivo > > > > de > > > > > > configuração, em: > > > > > > /etc/udev/rules.d/50-udev.rules > > > > > > por exemplo, o meu linux nao estava conseguindo ripar > > > um CD com usuário > > > > > > normal, ai adicionei a seguinte entrada: > > > > > > magno ~ # grep sg\\* /etc/udev/rules.d/50-udev.rules > > > > > > KERNEL=="sg*", NAME="%k", GROUP="cdrom" > > > > > > > > > > > > E passou a funcionar para usuários do grupo CDROM :) > > > > > > > > > > > > Só uma observação, a NVidia é muito boa, mas nenhum > > > processo opensource > > > > tem > > > > > > o dever de dar suporte a um aplicativo não GPL > > > > > > > > > > > > > > > > > > Em 15/09/05, Renata Romanazzi <natzilla@×××××.com> > > > escreveu: > > > > > > > > > > > > > > Oi, Rodolfo. Eu estou com o kernel 2.6.13, que não tem > > > mais suporte a > > > > > > > devfs. Eu tenho as linhas alias > > > no /etc/modules.d/nvidia e verifiquei > > > > > > > que no arquivo de regras do udev também tem o nvidia, > > > mas os devices > > > > > > > não são criados quando se carrega o modulo. > > > > > > > > > > > > > > Não cheguei a criar os devices na mão porque acho que > > > o udev deveria > > > > > > > fazer isso sozinho, então estou tentando fazer com que > > > o udev tome > > > > > > > vergonha e faça seu trabalho. > > > > > > > > > > > > > > On 9/15/05, Rodolfo Penha < rodolfo.penha@×××××.com> > > > wrote: > > > > > > > > Bem, não sei se alguém tentou seguir as minhas > > > dicas, mas vão ai > > > > > > > > novamente... > > > > > > > > > > > > > > > > Dê uma olhada no /etc/modules.d/nvidia e veja se > > > contém as linhas: > > > > > > > > > > > > > > > > alias char-major-195 nvidia > > > > > > > > alias /dev/nvidiactl char-major-195 > > > > > > > > > > > > > > > > Se não estiverem lá, adicione e dê um > > > modules-update. Veja se > > > > funciona. > > > > > > > > > > > > > > > > Caso ainda não funcione, crie os nodes da seguinte > > > forma: > > > > > > > > > > > > > > > > mknod /dev/nvidiactl c 195 255 > > > > > > > > mknod /dev/nvidia0 c 195 0 > > > > > > > > chown root:video /dev/nvidia{ctl,0} > > > > > > > > chmod 0660 /dev/nvidia{ctl,0} > > > > > > > > > > > > > > > > Adicione os usuários que vc queira que tenham > > > aceleração gráfica no > > > > > > > > grupo video. > > > > > > > > > > > > > > > > Creio que isto resolva. > > > > > > > > > > > > > > > > OBS: Meu RC_DEVICE_TARBALL está como "no" > > > > > > > > > > > > > > > > Outro detalhe: compilei o kernel com suporte a > > > devfs: > > > > > > > > > > > > > > > > rodolfo modules.d # zcat /proc/config.gz |grep DEVFS > > > > > > > > CONFIG_DEVFS_FS=y > > > > > > > > # CONFIG_DEVFS_MOUNT is not set > > > > > > > > # CONFIG_DEVFS_DEBUG is not set > > > > > > > > > > > > > > > > Porém desabilito no grub.conf e habilito o udev: > > > > > > > > > > > > > > > > title Gentoo Linux (Gentoo 2.6.12-gentoo-r6 - > > > Framebuffer) > > > > > > > > root (hd0,0) > > > > > > > > kernel > > > (hd0,0)/kernel-genkernel-x86-2.6.12-gentoo-r6 udev > > > > > > > > root=/dev/hda5 video=vesafb:ypan,1024x768-32@85 > > > gentoo=nodevfs > > > > > > > > > > > > > > > > > > > > > > > > Se alguém, obtiver sucesso com estas dicas, por > > > favor, envie um > > > > > > > > "feedback" para a lista. > > > > > > > > > > > > > > > > [ ]s > > > > > > > > > > > > > > > > Rodolfo Penha > > > > > > > > > > > > > > > > -- > > > > > > > > gentoo-user-br@g.o mailing list > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > -- > > > > > > > Renata Rocha > > > > > > > http://renata.org > > > > > > > 7409917@ICQ | saavik@××××××.org > > > > > > > renata@××××××××××××.net > > > > > > > > > > > > > > -- > > > > > > > gentoo-user-br@g.o mailing list > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > -- > > > > > > []s Magno > > > > > > http://magno.multiply.com > > > > > > -- > > > > > > Linux user: #123834 > > > > > > http://counter.li.org > > > > > > > > > > > > > > > -- > > > > > Renata Rocha > > > > > http://renata.org > > > > > 7409917@ICQ | saavik@××××××.org > > > > > renata@××××××××××××.net > > > > > > > > > > -- > > > > > gentoo-user-br@g.o mailing list > > > > > > > > > > > > > > > > > > > > > > > > > > -- > > > > []s Magno > > > > http://magno.multiply.com > > > > -- > > > > Linux user: #123834 > > > > http://counter.li.org > > > > > > > > > -- > > > Renata Rocha > > > http://renata.org > > > 7409917@ICQ | saavik@××××××.org > > > renata@××××××××××××.net > > > > > > -- > > > gentoo-user-br@g.o mailing list > > > > > > > > > > > > > > > -- > > > []s Magno > > > http://magno.multiply.com > > > -- > > > Linux user: #123834 > > > http://counter.li.org > > > > > > -----BEGIN PGP SIGNATURE----- > > Version: GnuPG v1.4.1 (GNU/Linux) > > > > iD8DBQBDKxrpXnKQhCGkniURAg4iAKC+4nl1/wqGA7fbg85iStZWmYSIQwCgkXkR > > oIQFgJMvElAeYisFDJc0CIo= > > =Lo03 > > -----END PGP SIGNATURE----- > > > > > > > > > -- > []s Magno > http://magno.multiply.com > -- > Linux user: #123834 > http://counter.li.org >
__________________________________________________ Do You Yahoo!? Tired of spam? Yahoo! Mail has the best spam protection around http://mail.yahoo.com -- gentoo-user-br@g.o mailing list

Replies

Subject Author
Re: Aviso (era -> Re: [gentoo-user-br] nvidia no gentoo não cria os nodes em /dev) Leandro de Araujo Teixeira <leandrolinux@×××××××××.br>