Gentoo Archives: gentoo-amd64

From: Simon Strandman <simon.strandman@×××××.com>
To: gentoo-amd64@l.g.o
Subject: Re: [gentoo-amd64] glibc-2.3.6-r3/glibc-2.4-r1 Compile Fail
Date: Fri, 31 Mar 2006 13:17:25
In Reply to: [gentoo-amd64] glibc-2.3.6-r3/glibc-2.4-r1 Compile Fail by Samir Mishra
Samir Mishra skrev:
> [Trying to get this message on to mailing list one more time (sigh)... > apologies in advance if duplicates of this message show up on mailing > list some time in the future.] > > Hello all, > > The installation CD is still in the drive, I started installation with > a stage3-amd64+multilib-2006.0 and have thus far only upgraded > gcc-3.4.4-? to gcc-3.4.5. > > I'm trying to set up a hardened system with gcc-4.1.0 & > glibc-2.3.6/glibc-2.4 is a prerequisite. Unfortunately compile of > glibc-2.3.6-r3 is dying with a "_rtld_global_ro" error. And > glibc-2.4.r1 is also failing. I would very much appreciate hearing > from anyone who's been successful in installing a similar setup.
One of the patches in glibc 2.3.6-r3 broke hardened on amd64 but 2.4-r1 should work. You'll need 2.4 for a hardened gcc 4 system anyway. I'm running a hardened x86 system with gcc 4.0 (rebuilding with 4.1 right now) and glibc 2.4 on my server so it's probably an amd64 specific issue.
> > I'll gladly provide more details as needed, reason I haven't done so > in this email because this seems to be an error that tends to pop up > frequently. > > TIA. > Samir. >
-- gentoo-amd64@g.o mailing list