Gentoo Archives: gentoo-dev

From: Benjamin Podszun <ben@××××××××××××××.de>
To: vaclav.hula@×××××××.cz
Cc: gentoo-dev@g.o
Subject: Re: [gentoo-dev] Performance once again..
Date: Mon, 14 Apr 2003 09:04:58
Message-Id: 1050311014.1280.70.camel@blafasel
In Reply to: Re: [gentoo-dev] Performance once again.. by "Václav Hůla"
On Mon, 2003-04-14 at 10:51, Václav Hůla wrote:
> On Saturday 12 of April 2003 21:09, Benjamin Podszun wrote: > > Hi there. > > I switched to Gentoo on two of my servers recently. Before that I used > > Debian stable with a 2.4.18-Kernel. > > Right now the machines are nearly useless. They should serve lots of > > pages, but every ~24h everything freezes without any load on the > > machines.. The load drops to 0.01 and nothing is delivered. > > Only a restart of apache resets this timeframe again. > > Have you tried to strace the apache? Somewhere in this post you wrote > something about one process eating lots of CPU, so maybe strace output of > this process may be helpful.
No, not yet. I could try to run strace on apache, but the biggest problem is not the CPU it uses.. The problem is that it just stops to work. Yesterday I got a "MaxClients reached" error and MaxClients is 200.. After that it didn't "recover" so I had to restart it before any new connections were possible. Since that happened 8h after I started the server again, I doubt that I can strace this particular problem? Or do I miss something? thx, Ben


File name MIME type
signature.asc application/pgp-signature


Subject Author
Re: [gentoo-dev] Performance once again.. Paul de Vrieze <gentoo-user@××××××××.net>