Gentoo Archives: gentoo-ppc-user

From: Stuart Mathews <stuart@×××××××××××××.com>
To: gentoo-ppc-user@l.g.o
Subject: Re: [gentoo-ppc-user] /etc/init.d/apache2 missing, and it should be
Date: Mon, 29 Dec 2008 06:22:13
In Reply to: [gentoo-ppc-user] /etc/init.d/apache2 missing, and it should be by Mark Knecht
Mark Knecht wrote:
> Hi all, > I need to actually learn a little Gentoo stuff. Thanks in advance. > > On my wife's machine there's an error message at boot time which says > > /etc/init.d/apache2 missing > > or something to that effect. Now I think I installed apache2 a long > time ago looking at some mythtv option but that's no longer used and > apache isn't on the system. However she gets this message at boot > time. > > Searching around I didn't see anything obvious about why this > happens. There's nothing sowing up with rc-update. However there is a > file > > /etc/runlevels/default/apache2 > > which I suspect is involved. Is it? Is it left over from some earlier > ebuild that didn't remove it? Can I remove it by hand and fix things > or is there some better tool for keeping this part of the machine > happy and healthy? > > Thanks, > Mark >
I broke my ibook with Gentoo a while back, so I can't test this out for you but have you tried to reinstall apache and then uninstall it cleanly? It looks like you have an entry in your default startup init script that looks for the apache init script and it cant find it ... try this to remove this reference : #rc-update del postfix default Kind regards, Stu


Subject Author
Re: [gentoo-ppc-user] /etc/init.d/apache2 missing, and it should be Stuart Mathews <stuart@×××××××××××××.com>