Gentoo Archives: gentoo-user-br

From: Alexandre Riveira <alexandre@××××××××××××××.br>
To: gentoo-user-br@l.g.o
Subject: Re: [gentoo-user-br] novo na lista e duvida sobre gcc 4.6
Date: Thu, 11 Aug 2011 12:00:24
Message-Id: CAL5QHYHDwOZiSghorVOnt2Nko+gUsbv3n4==h6a4Tpo+m8WD1A@mail.gmail.com
In Reply to: Re: [gentoo-user-br] novo na lista e duvida sobre gcc 4.6 by Zhu Sha Zang
Bom dia  Zhu !

Obrigado pela dica !
Minha preocupacao nem eh compilar muitas coisas e mais saber se o gcc
poderia gerar um binario instavel com relacao ao kernel especialmente, pois
acredito que, a cada nova versao, o gcc deve ter otimizacoes que nao sei se
afetariam a estabilidade do kernel.


Obrigado,


Alexandre Riveira


Em 11 de agosto de 2011 08:32, Zhu Sha Zang <zhushazang@×××××××××.br>escreveu:

> Minha máquina principal, uso 4.4 por causa do nvidia-sdk. Em algumas > máquinas uso o 4.5 sem problemas, mas não testo tantos pacotes nela assim > para saber se tudo que VOCÊ precisar vai compilar. E com certeza utilizar o > 4.6 vai te dar dor de cabeça. Eu sugiro manter o gcc 4.4. > > Bem vindo e boa sorte. > > Em 10-08-2011 11:07, Pablo Hess escreveu: > > Seja bem vindo, Alexandre. >> >> O banco de dados de pacotes online do Gentoo indica que a versão >> estável mais recente do GCC nas arquiteturas x86 e amd64 é a 4.4.5: >> <http://packages.gentoo.org/**package/sys-devel/gcc<http://packages.gentoo.org/package/sys-devel/gcc> >> >. >> >> O gcc-4.6.0 e o gcc-4.6.1 estão mascarados, ou seja, ainda estão em >> fase inicial de teste ou encontram-se instáveis. >> >> As versões 4.5.x do GCC estão marcadas como instáveis, o que significa >> que elas podem ter problemas de compilação ou talvez ainda sejam >> incapazes de compilar softwares importantes do seu sistema. >> >> >> Minha duvida e confirmar se o gcc 4.4 e o padrao mesmo ! Pois na >>> distrowatch >>> consta na coluna stable o gcc 4.6.1. >>> >> É verdade. Um grande engano de quem quer que tenha informado isso. :( >> >> >> Outra questao seria se, ao compilar com a ultima versao do gcc se isto >>> poderia gerar uma instabilidade no sistema, >>> visto que, provavelmente, muitos softwares ainda nao foram testados nessa >>> versao. >>> >> Softwares compilados com uma versão muito recente do GCC não devem ter >> problemas de execução, mas podem ter de compilação. Ou seja, se você >> conseguir compilar com o GCC novo, ele deve funcionar direito. :) >> >> >> > > -- > > --- > Zhu Sha Zang > > >