Gentoo Archives: gentoo-user

From: lee <lee@××××××××.de>
To: gentoo-user@l.g.o
Subject: [gentoo-user] update problems
Date: Sat, 19 Sep 2015 19:36:35
Message-Id: 87eghucic9.fsf@heimdali.yagibdah.de
Hi,

how could I solve these updating problems:


emerge -j 8 -a --update --newuse --deep --with-bdeps=y @world                                                                                                                                                                   

 * IMPORTANT: 4 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/boost:0

  (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/boost-1.55.0-r2:0/1.55.0::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/boost:0/1.55.0= required by (dev-libs/librevenge-0.0.2:0/0::gentoo, installed)
                  ^^^^^^^^^^                                                                                                   
    (and 2 more with the same problem)

dev-util/boost-build:0

  (dev-util/boost-build-1.55.0:0/0::gentoo, installed) pulled in by
    =dev-util/boost-build-1.55* required by (dev-libs/boost-1.55.0-r2:0/1.55.0::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                           

  (dev-util/boost-build-1.56.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =dev-util/boost-build-1.56* required by (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                           

media-video/ffmpeg:0

  (media-video/ffmpeg-2.6.3:0/54.56.56::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-video/ffmpeg-2.2.14:0/52.55.55::gentoo, installed) pulled in by
    media-video/ffmpeg:0/52.55.55=[vdpau] required by (media-libs/mlt-0.9.0:0/0::gentoo, installed)
                      ^^^^^^^^^^^^                                                                                                     


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The ebuild selected to satisfy "sci-libs/hdf5" has unmet requirements.
- sci-libs/hdf5-1.8.14-r1::gentoo USE="cxx fortran threads zlib -debug -examples -fortran2003 -mpi -static-libs -szip"

  The following REQUIRED_USE flag constraints are unsatisfied:
    threads? ( !cxx !fortran )

  The above constraints are a subset of the following complete expression:
    cxx? ( !mpi ) mpi? ( !cxx ) threads? ( !cxx !mpi !fortran ) fortran2003? ( fortran )

(dependency required by "media-libs/openimageio-1.3.5::gentoo" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


I could remove boost (and maybe reinstall it later), but I would like to
keep ffmpeg.  hdf5 apparently goes back to having blender installed,
which I would also like to keep.  And apparently, I would have to remove
libreoffice before I could update.

Why can't we just update like we can with any other distribution but
have to run into dependency problems all the time instead?

What do I do when I need to update /right now/ and find myself being
blocked with cryptic messages like the above that leave me stranded?
Once I used 'emerge --sync', there is no way to turn it back to continue
to be able to install software if needed when the update cannot be
performed.  Updates simply need to work, there's no way around that.


-- 
Again we must be afraid of speaking of daemons for fear that daemons
might swallow us.  Finally, this fear has become reasonable.

Replies

Subject Author
Re: [gentoo-user] update problems Alan McKinnon <alan.mckinnon@×××××.com>
Re: [gentoo-user] update problems Neil Bothwick <neil@××××××××××.uk>
Re: [gentoo-user] update problems Daniel Frey <djqfrey@×××××.com>