Gentoo Archives: gentoo-user

From: Dale <rdalek1967@×××××.com>
To: gentoo-user@l.g.o
Subject: Re: [gentoo-user] cannot emerge @preserved-rebuild due to removed package...
Date: Sat, 14 Mar 2015 08:12:16
Message-Id: 5503ED52.6070907@gmail.com
In Reply to: [gentoo-user] cannot emerge @preserved-rebuild due to removed package... by Meino.Cramer@gmx.de
Meino.Cramer@×××.de wrote:
> Hi, > > emerge hits me: > > Whiletrying to reolve a lot of blockers, emerge @preserved-rebuild > gives me this: > > emerge: there are no ebuilds to satisfy "kde-base/solid:4". > (dependency required by "@preserved-rebuild" [argument]) > > emerge itself can be called without that error. > How can an argument to a command haves a dependency? > > How can I get out of this? > > Best regards, > mcc > > > >
Hmmmm. root@fireball / # equery list -p solid * Searching for solid ... [-P-] [ ~] kde-frameworks/solid-5.7.0:5/5.7 root@fireball / # It seems there is no 4 versions. Do you perhaps have a 4 version listed in your world file that sneaked in there somehow? If so, removing that may allow a upgrade. If not, interesting problem. Dale :-) :-)

Replies