Gentoo Archives: gentoo-user

From: Grant Edwards <grant.b.edwards@×××××.com>
To: gentoo-user@l.g.o
Subject: [gentoo-user] Re: How to diagnose version conflicts?
Date: Wed, 12 Jan 2022 00:44:54
Message-Id: srl89p$okh$
In Reply to: Re: [gentoo-user] How to diagnose version conflicts? by Jack
1 On 2022-01-12, Jack <ostroffjh@×××××××××××××××××.net> wrote:
3 >> python-exec-2.4.8 requires python-exec-conf which requires
4 >> python-exec 2.4.6?
5 >
6 > I was going to wonder if you are caught in the middle of an upgrade
7 > that's only partly reached the mirrors. Given that (as I see it,
8 > having last done a sync a few hours ago) that there is ONLY one version
9 > each in the tree for python-exec-2.4.8 and python-exec-conf-2.4.6.
11 Yep, same here.
13 > However, looking at the ebuilds:
14 > python-exe requires python-exec-conf (no version specified)
15 > python-exec-conf-2.4.6 requires "!<dev-lang/python-exec-2.4.6-r4" which
16 > should allow 2.4.8.
17 >
18 > I have both python 3.9.9-r1 and 3.10.0_p1-r1 installed (plus
19 > 2.7.18_p13) so there doesn't seem to be any conflict there. What does
20 > "equery d python-exec" tell you?
22 After poking around a bit, I realized that the only machine that was
23 having this problem was also the only one that had python2.7
24 installed. Python 2.7 was required by ipkg-utils (for which the ebuild
25 seems to have long since vanished). The only thing I ever use from
26 ipkg-utils is the ipkg-build bash script. I copied that script to
27 ~/bin/ and unmerged ipkg-utils.
29 emerge --depclean then removed python2.7, and then emerge -auvND
30 happily upgraded python-exec to 2.4.8.
32 Still not sure what command one uses to determine what package is
33 preventing some other package from being upgraded...
35 --
36 Grant


Subject Author
Re: [gentoo-user] Re: How to diagnose version conflicts? Arve Barsnes <arve.barsnes@×××××.com>