Gentoo Archives: gentoo-user

From: tuxic@××××××.de
To: Gentoo <gentoo-user@l.g.o>
Subject: [gentoo-user] One package needs two other packages, which cannot be installed simultanously?
Date: Tue, 14 Nov 2017 01:00:49
Message-Id: 20171114010028.6puriuof22r32kzi@solfire
Hi,

I got this:

* Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (net-libs/rpcsvc-proto-1.2-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    net-libs/rpcsvc-proto required by (net-analyzer/dsniff-2.4_beta1-r9:0/0::gentoo, installed)
                                                    ^^^^^^^^^^^^^^^^^^^^^^^


  (net-libs/libnsl-1.1.0-r1:0/2::gentoo, ebuild scheduled for merge) pulled in by
    net-libs/libnsl:0 required by @__auto_slot_operator_replace_installed__
    net-libs/libnsl:0= required by (app-emulation/hercules-3.12:0/0::gentoo, installed)
    net-libs/libnsl:0= required by (app-text/opensp-1.5.2-r6:0/0::gentoo, ebuild scheduled for merge)
    net-libs/libnsl:0= required by (net-analyzer/dsniff-2.4_beta1-r9:0/0::gentoo, installed)
                                                 ^^^^^^^^^^^^^^^^^^^^^^^


It looks like deoends on packages, which could not be installed at the
same time on the same system.

Or am I wrong?

Cheers
Meino

Replies